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Chapter 1. Introduction
1.1. About Cartographica

Cartographica™ is a Geographic Information System (GIS) package for the Macintosh. It is used to create,
analyse and present geospatial data.

1.2. Projections, Coordinate Systems, and Datum
Mapping the Earth requires a mathematical projection that enables us to view a spherical body on a two-
dimensional surface. The problem of representing a sphere on a 2-D surface is that in almost all cases at
least some part of the map becomes distorted due to the curvature of the Earth. To account for this problem,
we have created Geographic Coordinate Systems (GCS) and datums to better represent our objects of
study. Geographic Coordinate Systems contain X, Y, and Z data that provide standardized locations of
objects on Earth. X coordinates generally describe longitudinal data, Y coordinates describe latitudinal
data, and Z coordinates typically describe an elevation. Not all GCSs are the same once projected on a
map because they are based on different datums that allow for specificity in mapping.

Geographic Coordinate Systems must be defined by a datum, which are sets of reference points on the
Earth’s surface. Because there are literally an infinite number of ways to view the Earth, it is critical to
account for distortion in specific areas. For example, if we are studying the dispersion of moose in Alaska
then we would likely not want to use the same datum in a study of kangaroo in Australia. Using specific
datums allows us to get the most accurate depiction of the location that we are studying.

Generally, GIS programs such as Cartographica can quickly translate datums if they are originally projected
on different or non-specific datums.

A common translation that users might encounter is if data isn't projected using the WGS 84 datum. WGS
84 or World Geodetic System (1984), is a standard datum for many GIS and GPS devices, and is the only
world wide datum. A user that brings in data collected from a GPS device and then attempts to map the
data with a specific datum, might find that their map is not accurately projected. Cartographica can account
for this by translating data to an already established datum like WGS 84. We have incorporated NTv2
support to provide accurate mapping between NAD27 and NAD83.

1.3. Features
Cartographica's most basic unit of information is an Feature. A feature is a geometric container for inform-
ation. Usually, we represent a feature as a point, line, polygons, or imagery. Point data is the most basic
and represents a location in 2d or 3d space. Line data is the next most complex and represents a series of
points in a particular direction which are connected. Polygon (also sometimes called Area) data is the most
complex data and represents a series of points which surround an area, optionally containing "holes" that
cut areas out.
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Figure 1.1. Data Features

1.3.1. Multi-part Features
All feature types are available in single and Multi-part features. Multi-part features provide a way to consider
a group of geographical elements as a single unit. This can be helpful for representing many types of data.
For example, multi-point features (multi-part points) can represent grouped locations for a particular event
type or time period; multi-line features can deal with maintaining a single record for a road that is discon-
tinuous; and multi-area features can provide a single feature to represent an archipelago. These are just
examples, and you can use them in unique ways to represent your data.

1.4. Layers
In Cartographica, data is organized into Layers. A Layer consists of one type of data (point, line, area, or
imagery), and contains one or more features of each type. Each of these features usually contains geospatial
information (one or more sets of X,Y and possibly Z coordinates) as well as optional reference data that
describes characteristics of the features in the layer. It is the attachment of the reference additional data to
the geospatial information that makes a GIS like Cartographica so powerful. By using the geospatial data,
correlations can be made between information in the reference data, leading to informative maps and in-
sightful data analysis.

2
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Layers Composite

Figure 1.2. Layers Alone and Composited

1.4.1.Types of Layers
Cartographica uses a number of different types of layers to represent data in MapSet. Each one can be en-
abled or disabled, and can have various attributes manipulated, as appropriate.  A basic description of each
is included here.

Table 1.1. Layer Descriptions

DescriptionLayer

Vector layers are comprised of lines, points, or
polygons. There are many tools that can use the

Vector

Vector layers for data analysis and manipulation.
Common uses are representing discrete locations
(points), roads or rivers (lines), and areas (polygons).

Raster layers are comprised of a grid of individual
data cells that can be interpreted many ways. Com-

Raster

mon uses are representing height or depth data, con-
taining data for frequency or counts of incidents in
specific locations, or providing color or false color
data from satellite imagery. There are specialized
tools in Cartographica to process Raster data, includ-
ing computing topography, and merging with similar
data.

Grid layers provide geospatial context to other layers.
When added to maps, they render a grid of lines de-

Grid

marcating areas in the Map or Layer reference sys-
tem.

3
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DescriptionLayer

Analysis layers are specialized Raster layers. They
contain not only the resultant raster data from an

Analysis

analysis, but also the parameters used to make that
analysis.

4
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Chapter 2. Getting Started with
Cartographica
2.1. Installing Cartographica

Cartographica is delivered over the internet in a standard Macintosh disk image, which is just a way to
package Macintosh programs and files so that they are not harmed during transport across the Internet.

For those who are not familiar with this kind of software delivery, it can be a bit confusing. The disk image
acts just like a CD inserted into your Macintosh, but without the physical media. Once the disk image
shows up on your computer, the contents only stay there until you Eject the disk image from the Finder.

Although it is possible to run Cartographica from the disk image, it is not suggested, as it can become
confusing to have to reload the disk image (and re-accept the license agreement) each time you run the
program.

The Cartographica disk image contains the license agreement and may contain additional information
along with the program itself.

Procedure 2.1. Installing Cartographica from the disk image

1. Locate the Cartographica disk image in the Finder

If you have just downloaded it from the MacGIS.com site [http://www.macgis.com], the disk image
will be inside of your default download folder.

2. Double-click on the disk image file to open it

The Cartographica license agreement window will appear. Read through the agreement until you are
satisfied that we aren't doing anything bad.

3. Click Accept to continue

The contents of the Cartographica disk image should now be visible in the Finder.

5
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Figure 2.1. Cartographica Disk Image

4. Drag the Cartographica program icon from the disk image into your Applications folder

You can place Cartographica almost anywhere you like, but the standard practice on the
Macintosh is to use the Applications folder.

Cartographica is now installed and ready to run.

5. Choose Go > Applications in the Finder to open the Applications folder.

6. Optionally, drag the Cartographica icon from the Applications folder to the Dock if you want to be
able to access Cartographica quickly from the dock.

7. Double-click on Cartographica in the Applications folder or click on Cartographica in the dock
to get started.

2.2. Updating Cartographica
Cartographica has a built-in update service that helps to make sure that you have the most recent updates
to the software. When you run Cartographica for the second time, you will be asked if you would like to
let Cartographica check for updates. We strongly suggest that you allow Cartographica to do this check as
it will keep you informed of any important bug fixes and feature additions.

6
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You can always opt in or out of the automatic update process later by changing your update preferences.
Even if you opt out of the auto-update process, you can still use the updating mechanism in Cartographica
to check for updates manually.

Procedure 2.2. Changing your auto-update preferences

1. Choose Cartographica > Preferences… to bring up the Cartographica Preferences window

2. Check Automatically Check for Updates to enable the auto-updater and uncheck it to disable the
feature.

3. Advanced users may wish to subscribe to the Development or Beta versions of the software in order
to help test future features in Cartographica. Although it is suggested that most people leave the update
setting at Release, you can change it to Beta or Development if you are instructed to do so.

4. Optionally check Sends System Profile Information if you want to help out ClueTrust by sending
along some basic (non-identifying) statistical data about your computer when you check for updates.

Procedure 2.3. Manually updating Cartographica

1. Choose Cartographica > Check for Updates…

If there is a new version of Cartographica available, you will be presented with information about
changes in the updated software and given the option to install it or to defer until later.

2. Click Install Update to being the update process

Cartographica will download the new version while you work and then prompt you later to install the
new copy.

3. Click Install and Relaunch to shut down Cartographica, install the new version, and restart the pro-
gram.

Once Cartographica restarts, you're ready to use the new version.

2.3. Interface Overview
When you initially open a Cartographica map the Map Window appears. Figure 2.2, “Main Cartographica
window” shows that window with a map already loaded in it. This window is the centerpiece of Cartograph-
ica and where most of the work is done. In the figure we have shaded various sections of the window for
purposes of explaining the layout and function of each of the sections.

7
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Figure 2.2. Main Cartographica window

Toolbar The Toolbar at the top of the window provides access to often-used functions
in Cartographica.

As with all toolbars on the Macintosh, it is optional and may be hidden, resized,
or changed by using the Toolbar Button in the upper right corner of the window
or View > Customize Toolbar…

Layer Stack The layer stack shows the list of all layers in the map document and provides
an easy way to re-order layers, change styles, and show or hide individual layers.

The selection in the Layer Stack provides guidance to the Map View and Data
View as to which data is selectable.

Warning Triangles in the Layer Stack

You may see a warning triangle in the right side of the Layer Stack. If
this happens, click on the triangle to find out more about the problem
is with the layer, and potential fixes. The most common cause of the
warning triangle is a layer that has no valid CRS.

Map View The powerhouse of Cartographica, the Map View shows your geospatial data
in context with all of the visible layers.

8
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Data View The Data View is used to show and edit data for the vector layer selected in the
Layer Stack.

Zoom The Zoom area is used to control and display zoom information about the Map
View. The Zoom Dial can be used like a slider to zoom out (slide up) or zoom
in (slide down). Below the Zoom Dial is the Zoom Factor Box which shows the
percentage zoom in effect right now. Typing a new value in this box will change
the zoom level directly.

Advanced Filters The Advanced Filters area is not always visible, but once you have started per-
forming a filter operation (using the Filter box in the Toolbar), it will pop into
view. Advanced filters provides for boolean operations so that you can search
and filter on more than one variable at a time.

2.3.1. Utility Windows
Cartographica uses Utility Windows (sometimes called palettes) that float above other windows in order
to provide access to more information about the current context. The content of these windows is synchron-
ized to the current Map Window, so if you have more than one Map open, they will change when you
switch back and forth between the Map Windows. Each of the Utility Windows is accessible via the
Window menu.

Measurements The Measurements Window provides information about the position directly
underneath the cursor or the current selection when dragging. See Section 4.5,
“Measuring Distance and Area” for details on how to bring up and use the
Measurement window.

Figure 2.3. Measurements Window
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Layer Info The Layer Info Window provides information about the layer currently selected
in the Layer Stack. Changes made in this window affect the data in the selected
layer.

Figure 2.4. Layer Info Window

Legend The Legend Window provides a quick reference to all of the layer styles in
the current Map.

Figure 2.5. Legend Window
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Image Viewer The Image Viewer Window provides an enhanced view of any pictures refer-
enced by a feature using the Picture item in the Style window.

Figure 2.6. Image Viewer

Selection Info The Selection Info Window provides a concise view of all selected objects.
On the left is a list of all features currently selected and the layer that they be-
long to. On the right is the information about the selected feature.

Figure 2.7. Selection Info Window
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Point Data The Point Data Window provides a detailed of all points in geometry of the
selected feature. On the left is a list of all parts (all geometries have at least
one part if they have any points). On the right is a list of all points in that part.
Point information may be edited manually in this window. It is important to
remember that all coordinates in this window are in the layer's coordinate
system, not in the map's coordinate system.

Figure 2.8. Point Data Window

Selection Summary The Selection Summary Window provides a statistical summary of a single
column of the selected objects. The Column drop-down determines which
column's data is summarized for the selection.

Figure 2.9. Selection Summary Window
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2.3.2.The Uber Browser
The following items are shown inside of the Uber Browser window. The Uber Browser provides a single
location to choose from built-in and user-saved symbols, palettes, bookmarks, and other items that are
used across all maps. Since Cartographica supports drag-and-drop to do many things, it serves as the
starting point for dragging into other windows. Each tab in the Uber Browser will be described separately
in this document, as the tabs themselves are where the content lies, however each is accessed through the
Uber Browser, which can be shown by using Window > Show Uber Browser.

Each tab is described below:

Symbols The Symbols tab provides access to all built-in and user-defined symbols in Cartographica,
for use when changing styles for point layers. For more information, see Figure 2.10,
“Symbols Tab”

Figure 2.10. Symbols Tab
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Lines The Lines tab provides access to all built-in line styles in Cartographica, for use when
changing styles for line layers and outlines in polygon layers. For more information, see
Figure 2.11, “Lines Tab”

Figure 2.11. Lines Tab
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Patterns The Patterns tab provides access to all built-in and user-defined pattern swatches in Carto-
graphica, for use when changing styles for polygon layers. For more information, see
Figure 2.12, “Patterns Tab”

Figure 2.12. Patterns Tab
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Bookmarks The Bookmarks tab provides access to all built-in and user-defined geographical bookmarks
in Cartographica, for use when navigating and exploring in the map window. For more
information, see Figure 2.13, “Bookmarks Tab”

Figure 2.13. Bookmarks Tab
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Palettes The Palettes tab provides access to built-in and user-defined color palettes that Cartographica
can use for vector and raster data. This window provides for selection of palettes as well
as creating and editing them. For more information, see Chapter 14, Color Palettes

Figure 2.14. Palettes Tab

2.4. Drag and Drop throughout Cartographica
Drag and drop is used extensively throughout Cartographica where it is reasonable. Usually it provides a
shortcut to some functionality elsewhere in the program's menus and windows. A few of these drag and
drop shortcuts are elaborated here, but if it makes logical sense to drag and drop something it will most
likely work.

• Drop vector or raster files on the map window to import them.
• Drop picture files that have lat & long on them into the window and they'll be plotted in a new layer on

the map.
• Drag layers to reorder them in the layer stack.
• Drop one layer on another to copy the styles.
• Drop a color swatch from the color picker onto the map background and change the background.
• Drag a layer from one map window to another in order to create a new copy of that layer in the map you

drop it on.
• Drop a map icon (grabbed from the title bar) into a Map Layout document to add a map copy there.
• Drop color maps onto analysis layers to change the color map.

2.5. Undo everywhere
Since one of Cartographica's key goals is to help you understand your data better, we believe it is important
to be able to quickly experiment with new ways of looking at your data. To help with this, Cartographica
is replete with undo and redo capabilities, making it possible to experiment with new ideas to your heart's
content without having to fear that you'll do something you can't undo.
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Chapter 3. Importing Data into
Cartographica
3.1. Overview

Cartographica is commonly used to provide visual interpretations and facilitate analysis of geospatial data.
Most data that is analyzed in Cartographica is not created or produced internally. Instead, users typically
add data into the maps that have been previously obtained from entities like government agencies or private
businesses.

Cartographica imports data from many sources. Using algorithms created by the ClueTrust team and by
the folks who create, maintain, and contribute to Geospatial Data Abstraction Library (GDAL), Cartographica
is able to bring in data from an enormous number of sources, including (but not limited to):

• ESRI® Shape Files
• MapInfo® MAP Files
• USGS DEM and DRG files
• Ordnance Survey and GML files
• ESRI Personal Geodatabase
• GPX files
• KML files
• ESRI File Geodatabase

The types of files you will use as source data will vary depending upon what you have available and what
specific needs you have. The general kinds of data that Cartographica can import are:
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Vector Files Files that contain referenced data in numeric form that can be scaled
up to the resolution of the data. Vector data includes data such as
points, lines, and polygons.

Raster Files Files that contain picture information (such as an orthophoto) or
data sampled at a specific resolution as point sources. Raster Data
includes data such as pictures or satellite images, as well as sample
grids and height or depth data.

Text Files (or Table Data) Text files can be used to bring in simple geospatial data (such as
points) or to merge in adjunct information, and usually contain lists
of values (or fields). Table data include comma separated values
(csv) and tab separated values (tsv). Text/Table import supports a
variety of character sets, including UTF-8, WindowsLatin1, and
others. If you are using a non UTF-8 character set, it's best to set
that when opening the file.

GPS Data GPS Devices provide location information sampled at a particular
point in time. For most purposes, these are waypoints (point sources
marked by the GPS User) and tracks (timestamped record of the
device's travels).

Database Information Databases can contain many of the types of data already described
above. Although they usually most similarly resemble Text Files
(fields of data and possibly simple geospatial data), some database
formats contain complex geometry.

Figure 3.1. Common File Types

For many applications, a single Cartographica Map Set will contain multiple layers loaded from more than
one type of file or other data source. For example, vector data is often used with an underlying raster image
in order to show it in the context of an aerial photo.

With Version 1.2 of Cartographica, we have introduced the ability to use dynamic maps as well as the
static maps that we have described so far. These can take on a number of different forms, including vector
data and raster imagery and can come from a variety of sources.
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MapBox® MapBox provides images for use as background maps in Cartographica
(and other programs as well as many web sites). The images available in-
clude satellite imagery, roads, and a hybrid combination of the two. MapBox
access is available if you have an active maintenance contract for Carto-
graphica, or your own MapBox access key.

Bing™ Maps Bing Maps provides images for use as background maps in Cartographica
(and other programs as well as many web sites). The images available in-
clude satellite imagery, roads, and a hybrid combination of the two. Bing
Maps access is available only if you have your own Bing Maps key for ac-
cessing the system.

OpenStreetMap OpenStreetMap is a service and an informal protocol. Although the original
OpenStreetMap is a service run from the UK which provides street-level
map data which has been put together on a volunteer basis around the world,
the URL pattern used by OpenStreetMap has now become an ad hoc
standard and is also used by other providers.  Cartographica can support
any tiled data source that uses the OpenStreetMap URL pattern.

Web Map Servers Web Map Servers are servers that use the WMS protocol, defined by the
Open Geospatial Consortium (OGC). This protocol is widely used in private
and public systems and a growing amount of data is available using it. WMS
data is by nature raster data, meaning that it carries no attributes with it. It
is most commonly used as background imagery or to offload complex
overlay tasks to a server so that clients do not need to merge multiple layers.

Web Feature Servers Web Feature Servers are servers that use the WFS protocol, also defined
by the OGC. This protocol is widely used in private and public systems and
a growing amount of data is available using it. Unlike WMS, WFS serves
data which is, by nature, Features and therefore vector. Data from these
types of services may be used in analysis and more flexibly understood.

Figure 3.2. Server-Based Formats

3.2. Importing Vector Files
Vector files contain geospatial information and often have accompanying reference data that describes the
data in the files.

Procedure 3.1. Importing Vector Files

1. Choose File > Import Vector Data….

The standard file chooser will come up

2. Select the vector file to import and click OK

If you have more than one file to import, you can either select multiple items during this import.

The projection of the map will be set by the first layer added, and projections of each file will be re-
corded as loaded to make sure each layer is reprojected correctly.

Vector imports are quite straightforward and usually do not require any additional decision
making, but in the event that your data is in a non-standard character format, you can override

20

Importing Data into Cartographica



the automatic character format detection and select it explicitly. Data loaded from these files
is inserted into the Cartographica system as points, lines, or polygons (as appropriate) and
any per-feature data is added as necessary.

3. Once you have imported the data, choose Layer > Set Layer Projection… to confirm that the co-
ordinate system of the data is accurately selected

3.2.1. Characters and Encodings
For shapefiles, Cartographica attempts to figure out what kind of encodings are used in the files by first
checking for a ".cpg" file (which will be written by ESRI's products when attempting to write out files that
don't conform to specifications in the DBF format), then looking at the LDID inside of the ".dbf" file itself.

If that fails, the presumption is that the data is in ISO Latin 1, which is the default for older files. We have
confirmed success working with UTF-8 and many other character sets, but since not all characters are
represented in the schemes other than UTF-8, there is the potential for losing some data when exporting
to other character formats.

In the case of GML and KML, the imported data is presumed to be Unicode UTF-8 (unless specified oth-
erwise in the file itself, since there exist ways to do that in these XML-based formats). Other file types
may use specific characters set in the import window.

3.3. Importing Raster Data
Raster files contain data whose form is that of samples in some form of matrix. The most common example
of this kind of file is an orthophoto image file (such as a JPEG). In these files, the data provided are color
information and the matrix is the frame of the picture. Cartographica supports the efficient use of large
Raster files (tested up to 5GB).

Raster files can take on many forms. Some of the more common forms you may want to import include:

• USGS DRG files consisting of georeferenced photo data

• DEM (Digital Elevation Model) Files contain elevation data in a point matrix

• Orthophotos - aerial photos that are geometrically corrected to make the scale uniform

Procedure 3.2. Importing Raster Files

1. Choose File > Import Raster Data.

2. Select the file to import and click Open.

If you have more than one file to import, you may select multiple items during this import.

Some raster data is not georeferenced and may not be positioned correctly on the map. See Section 9.2,
“Georeferencing Raster Layers (side-by-side)” to solve this problem.

3. Once you have imported the data, choose Layer > Set Layer Projection to confirm that the coordinate
system of the data is accurately represented (including Datum and Projection).

Once the data is imported, you can use the dedicated layer style window for raster layers to display and
change the color palette applied to the raster data. This is particularly useful for files such as DEM, in
which samples are made up of floating-point or integer information instead of colors. In addition, by using
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the Tools > Merge Selected Raster Layers you can place more than one dataset in the same layer, forcing
them all to use the same palette over the same range. In automatic mode, the range is the range of all
datasets in the layer. In manual mode, the range is determined by the user.

3.4. Importing Text Files and Table Data
Cartographica can import text files that contain tables as geospatial and data sources. Cartographica can
use text files (either CSV, TSV or DBF) to provide three different types of data:

Coordinate data Coordinate data contains either X,Y coordinates or latitude and longitude.

Address data Address data contains postal addresses.

Tabular data Tabular data contains no geospatial information.

Because there is a great variety of sources and types of data which originate in non-geospatial files, Carto-
graphica has a few mechanisms that are used consistently in many of our importing systems.

3.4.1.The Import Map
Cartographica uses the Import Map when importing tabular data (Section 3.4.2, “Importing data from Text
and DBF files”) and acquiring database data (Section 3.5, “Acquiring Database Data”). It serves two pur-
poses: first to determine how to associate new data with an existing or new layer, and second, to determine
how to relate the imported data geospatially to the rest of the data in the map.

Figure 3.3. Import Map

The left side of the Import Map window is used to define the relationship between fields within the file or
database that is being imported and the layer that they are being imported into. The meaning of each column
is detailed here.
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Field Name The name of the field being imported. Based either on the initial line of the file or the
database source that the data is coming from.

Type The kind of data being imported (String, Number, Date, etc). This is determined either
directly from the import source or by heuristic. If necessary, the type information may
be overridden by choosing a different type in the Type menu.

Map To Determines which column this field will map to in the resultant layer. When set to New
Column, a new column with this name will be added to the table. Special values for
geocoding and Coordinate import are also available. Existing fields are listed if the target
layer is not new. - Do Not Import -  tells Cartographica not to import this field at all.

Key The Key field is only used for the Join style of importing, and we be detailed in section
REFERENCE. When the Key box is checked, the corresponding relationship between
the imported field and the Map To field is used to determine which feature to associate
a row from the data file with.

3.4.2. Importing data from Text and DBF files

Procedure 3.3. Importing files containing coordinate data

1. Choose File > Import Table Data….

The import table file chooser appears.

Figure 3.4. Import Table File Chooser

This chooser is a standard file chooser with a few additional options to control how the text is inter-
preted. The character set may be chosen, overriding the default character set in the file. For text files,
you may also tell Cartographica to consider the first line of the file to contain field names (the default),
and designate the column separator and number format.

2. Select the location of the text or table file you want to import and click Open.
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The Import Map window appears and describes the format of the file and requests that you determine
how it should interpret the data as it is read.

3. Using Target Layer select an existing layer to append the data to, or choose New Layer.

4. Choose Coordinates from the right hand set of tabs in the window. This will enable coordinate import
mode.

Because you are in coordinate import mode, the choices in your Map To column include X (or lon-
gitude) Y (or latitude), Z (or altitude) and M (or time) along with the standard options of - Do Not
Import - , New Column, and any columns that exist in your selected target layer.

5. Using the Import Map (as described in Section 3.4.1, “The Import Map”, map the incoming data fields
to your selected layer, making sure that you map at least one column to the X and Y coordinates.
Without both of these, Cartographica cannot place the data on the map.

6. Click Import to import your data into the map.

Cartographica will read the data from the file, interpret the columns to the best of its abilities and
store them into the requested layer.

7. Once you have imported the data, choose Layer > Set Layer Projection to confirm that the coordinate
system of the data is accurately represented.

Procedure 3.4. Importing files containing address data

Before importing address data, the geocoder must be appropriately configured. This is an easy process,
outlined in Section 8.7, “Geocoding Addresses”.

1. Choose File > Import Table Data….

The import table file chooser appears.

2. Select the location of the text or table file you want to import and click Open.

The Import Map window appears and describes the format of the file and requests that you determine
how it should interpret the data as it is read.

3. Using Target Layer select an existing layer to append the data to, or choose New Layer.

4. Choose Geocode from the right hand set of tabs in the window. This will enable address geocoding
mode.

Because you are in address geocoding mode, the choices in your Map To column include Address
1 through Address 4, City ,State ZIP, ZIP+4, and Country along with the standard options of - Do
Not Import - , New Column, and any columns that exist in your selected target layer.

5. Check the Include Diagnostics box if you want Cartographica to include additional diagnostic and
position information obtained through geocoding

6. Using the Import Map (as described in Section 3.4.1, “The Import Map”, map the incoming data fields
to your selected layer, making sure that you map at least one column to Address 1. If it is the only
column specified, then it will be presumed to have a full address in it.

7. If necessary, fill in one or more of the City, State, or Country boxes in the right pane. These act as
defaults for the geocoder in the event that there are no columns that match. Often city data is delivered
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with only the street portion of the address, and these fields can be used to limit the search to that
particular city.

8. Click Import to import your data into the map.

Cartographica will read the data from the file, interpret the columns to the best of its abilities using
the geocoding specifications and store them into the requested layer.

9. Once you have imported the data, choose Layer > Set Layer Projection to confirm that the coordinate
system of the data is accurately represented.

3.5. Acquiring Database Data
Acquiring database information works similarly to Section 3.4, “Importing Text Files and Table Data”,
except that instead of reading the data from a data file, it is read from a database. By using Open Database
Connectivity (ODBC) Cartographica is compatible with a wide variety of file formats and database systems
(including, but not limited to: Filemaker Pro, Oracle, MySQL, PostgreSQL, and many others). We test
against Actual Technologies [https://www.actualtech.com] ODBC drivers for macOS, as they are the
strongest player in the market.

As with importing tables, Cartographica uses the Import Map (Section 3.4.1, “The Import Map”) in order
to map incoming data to coordinates or addresses.

Due to the nature of the ODBC drivers on the Macintosh, there are some compatibility issues with
older drivers under 10.6 and certain combinations of data and drivers. If you plan to import data
with ODBC, please visit the ClueTrust Help Center [https://support.cluetrust.com/hc/en-us] and
read the article on ODBC.

Cartographica currently does not support using external database as active storage for geospatial
data. As such, we support database imports for address, coordinate, and grid data, and can Join
geospatial and non-geospatial data, however we do not support the varied methods for storing
geospatial data directly in databases.

The trickiest part about reading data from a database using ODBC is setting up the ODBC connection on
the system. Although that task is beyond the scope of this manual, there are good documents available for
doing this from the vendors of the connection software. In particular, if you are using FileMake Pro, they
have a good site, and Actual Technologies provides excellent support for their crop of 64-bit drivers.

As with tables, database data can be interpreted in a variety of ways when it is imported to the system.
Coordinate imports, geocoding, and joins are all available for data from databases.

Procedure 3.5. Acquiring coordinate data from a database

1. Choose File > Acquire Database Data…

The Data Source window appears.

25

Importing Data into Cartographica

#dest=ImportingTextAndTables
https://www.actualtech.com
https://www.actualtech.com
#dest=UsingImportMap
https://support.cluetrust.com/hc/en-us
https://support.cluetrust.com/hc/en-us


Figure 3.5. Data Source Window

2. Select a Data Source and enter a User Name and Password if required.

3. Click Connect and Cartographica will retrieve and present a list of tables.

4. Choose a table from the Table menu to import and click Select.

5. Using Target Layer select an existing layer to append the data to, or choose New Layer.

6. Choose Coordinates from the right hand set of tabs in the window. This will enable coordinate import
mode.

Because you are in coordinate import mode, the choices in your Map To column include X (or lon-
gitude) Y (or latitude), Z (or altitude) and M (or time) along with the standard options of - Do Not
Import - , New Column, and any columns that exist in your selected target layer.

7. Refer to Section 3.4.1, “The Import Map” for details on how to map fields with the Import Map
window.

8. Once you have imported the data, choose Layer > Set Layer Projection to confirm that the coordinate
system of the data is accurately represented.

Procedure 3.6. Acquiring data from a database

1. Choose File > Acquire Database Data…

The Data Source window appears.

2. Select a Data Source and enter a User Name and Password if required.

3. Click Connect and Cartographica will retrieve and present a list of tables.

4. Choose a table from the Table menu to import and click Select.

5. Using Target Layer select an existing layer to append the data to, or choose New Layer.

6. Choose Geocode from the right hand set of tabs in the window. This will enable address geocoding
mode.
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Because you are in address geocoding mode, the choices in your Map To column include Address
1 through Address 4, City ,State ZIP, ZIP+4, and Country along with the standard options of - Do
Not Import - , New Column, and any columns that exist in your selected target layer.

7. At this point, you will be presented with an Import Map window. Please refer to Section 3.4.1, “The
Import Map” for details on how to use the Import Map window.

8. Refer to Section 3.4.1, “The Import Map” for details on how to map fields with the Import Map
window.

9. Once you have imported the data, choose Layer > Set Layer Projection to confirm that the coordinate
system of the data is accurately represented.

3.6. Joining Non-Geospatial Data
At times it may be necessary to add data to an existing layer by cross-referencing that data with another
table. Cartographica does this by matching columns in an existing layer with data from a file and adding
the new data to features which match. This operation is called a join in database parlance and by some GIS
packages.

To join data, use the Map To column to specify the destination column for the imported data (or New
Column if you want to add a new column for the imported data). Matching criteria is specified by checking
the Key box next to a column. Checking more than one Key box will only add the data when all Key fields
match.

As an example, here is some existing Polygonal data (Example Data A) for three Counties that exist in
two different States:

Table 3.1. Example Data A - Original Data

Area (Sq KM)  State Name County Name

1,020KentuckyFloyd

1,347VirginiaLoudoun

989VirginiaFloyd

(Note that Floyd counties exist in both states)

Here is the data you want to join with the above data (Example Data B):

Table 3.2. Example Data B

 2000 Census Population 1990 Census Population State NameCounty Name 

30,03338,033KentuckyBarren

8,2448,243IowaAdair

40,44142,441KentuckyFloyd

1,099,0001,077,000VirginiaFairfax

269,599169,599VirginiaLoudoun

Here is the result of performing the Join of Example Data B to Example Data A using County Name and
State Name columns as keys:
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Table 3.3. Result of original then joined by County Name and State Name as key

2000 Census Popu-
lation 

1990 Census Popu-
lation 

Area State Name County Name 

40,44142,4411,020KentuckyFloyd

269,599169,5991,347VirginiaLoudoun

989VirginiaFloyd

In the final table, the extraneous data supplied in Example Data B (Adair, Iowa and Barren, Kentucky)
which did not match entries in the existing table is discarded. Further, the lack of data about Floyd, Virginia
resulted in empty columns.

Note that if only the County Name was used as a key and all other columns were matched, then both Floyd
counties (the one in Virginia and the one in Kentucky would have values set in all columns, including re-
placing the State Name column. However, the explicit use of a multiple key means that Cartographica will
only consider a match when all elements match.

Table 3.4. Result of original joined with just County Name key

2000 Census Popu-
lation 

1990 Census Popu-
lation 

Area State Name County Name 

40,44142,4411,020KentuckyFloyd

269,599169,5991,347VirginiaLoudoun

40,44142,441989KentuckyFloyd

In the case that a feature in the layer matches multiple rows in the joined table, each row from the table
will replace columns in succession, resulting in the final feature data matching the last matching row in
the table.

3.7. Acquiring GPS Data
Cartographica supports loading data directly into a mapset from a wide variety of GPS receivers. Imported
data is represented as follows:

Table 3.5. Imported Data

Loaded as lines with each line containing a full track
and missing data being represented by discontinuous

Tracks

lines. Altitude is used as the Z coordinate. Time is
used as the M coordinate.

Loaded as individual points, with each point contain-
ing as much data as is available, Z coordinates are
set to altitude if available.

Waypoints

Loaded as continuous lines with each waypoint rep-
resented by a single point in the line. Altitude is
loaded in the Z coordinate if available. M is ignored.

Routes

Because of ClueTrust's long-standing efforts in Macintosh GPS connectivity (the free LoadMyTracks
software has been given away by ClueTrust since 2006), Cartographica supports a large number of GPS
devices for import. Please visit our support site for a detailed listing, but the classes of device and their
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manufacturers are listed in Table 3.6, “GPS Import Options” along with any special considerations for
each type.

Table 3.6. GPS Import Options

Import OptionsSpecial ConsiderationsGPS Type 

Tracks, Waypoints, RoutesMake sure that your Garmin USB
GPS is plugged in and turned on
before clicking Acquire.

Garmin USB

Tracks, Waypoints, RoutesSelect the serial port that your
Garmin GPS is connected to and
click Acquire.

Garmin Serial

Tracks, Waypoints, RoutesMake sure that your Garmin Stor-
age GPS is plugged in and turned
on before clicking Acquire.

Garmin Storage

TracksSelect the serial port that your
GlobalSat GPS is connected to and
click Acquire.

GlobalSat DG-100

Tracks, WaypointsSelect the serial port that your
GlobalSat GPS is connected to,

GlobalSat GH-615

activate Data Link to PC mode on
the GPS and click Acquire.

Tracks, Waypoints, RoutesMake sure that your Lowrance
GPS data card is plugged in and

Lowrance

mounted on the Desktop before
clicking Acquire.

Tracks, Waypoints, RoutesMake sure that your Magellan GPS
is plugged in and turned on and
that data transfer mode is selected.

Magellan GPS

Tracks, Waypoints, RoutesSelect the serial port that your
Magellan GPS is connected to be-
fore clicking Acquire.

Magellan Serial

TracksMake sure that your SONY GPS
is plugged in and turned on and
that data transfer mode is selected.

NMEA

TracksMake sure that your Timex Data
Recorder is plugged in and turned
on before clicking Acquire.

Timex

WaypointsMake sure that your TomTom GPS
is plugged in and turned on and
that data transfer mode is selected.

TomTom

Procedure 3.7. Acquire data directly from a GPS

1. Choose File > Acquire GPS Data.

The Import GPS Data window appears.
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Figure 3.6. Import GPS Data Window

2. Select the GPS type from the menu at the top of the window.

3. Choose one or more of Tracks, Waypoints, or Routes to include each of those in your import

4. If you would like an external record of your GPS download, check Save GPX File and a GPX file
will be created while the data is acquired

5. Click Acquire. The data is imported into Cartographica in a new layer.

It is not uncommon for tracks to come from GPS devices as single features with multiple
parts. Using Cartographica's Split Feature, you can break these down into their constituent
pieces. Similarly, if you have too many individual tracks, you can use the Merge Features
and Merge Selected Layers… features to bring those together.

3.8. Acquiring Images from Web Map Servers
(WMS)

There is an enormous amount of freely available or paid imagery available on the internet. Even after the
popularity of the internet grew, exchange of imagery data online was difficult due to the wide variety of
formats and protocols to access the data. This all changed with the creation of the Web Map Service (WMS)
protocol as part of the work of the Open Geospatial Consortium (OGC). WMS provides a standard mech-
anism for browsing and specifying imagery data available from servers online and declares certain standards
for the transport and representation of that data. Cartographica makes use of WMS to provide access to
this ready resource of data.

Procedure 3.8. Acquire data from a WMS Server

1. Choose File > Acquire WMS Data.

The Acquire WMS Data Window appears.

30

Importing Data into Cartographica



Figure 3.7. Acquire WMS Data Window

The server list (on the left) shows several WMS servers from which you can retrieve data. Once you
have selected a server in the list, the description box below the server list changes to give a description
of the selected server as broadcast from the server. The Source list on the right will display the options
available for the selected WMS Server.

2. Select the server in the left column

Cartographica will retrieve the current layer information from the server and present it on the right
Layer column

3. Select one or more layers on the right

The Layer list on the right shows layers that can be added to your maps from the Server. Data marked
with a red (-) cannot be added (usually because it is a category) and data marked with a green (+) can
be added. When one of these sources is selected, a description appears in the box below the Source
list.

In some cases, multiple layers can be added in the same request. If there is a limitation on the number
of simultaneous layers that may be chosen, it will be displayed in the lower left.

4. Select the Coverage Area to determine how much information is downloaded from the server. The
default Visible map bounds is generally suitable as it adds a margin around the current map's extent.
Selected layers will limit the bounds of the imagery to the extent of the selected layers, and Map
bounds will limit the bounds of the imagery to the extent of the current map, without any margin.

5. If want to download a copy to disk (as opposed to always fetching data from the server),
checkDownload as Static Imagery
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Checking this box will download a single map to your hard drive. The quality of the imagery when
you zoom will be decreased, but you will be able to work on the map even when you aren't connected
to the server, and your imagery will never change.

6. Click Retrieve to add the data to your map.

Procedure 3.9. Add New WMS Server

When you have the WMS Server sheet visible, you can add more servers to the source list on the left

1. Click the Add (+) button at the bottom of the left column to start adding a new server

The Add new WMS Server window appears.

Figure 3.8. Add Map Server sheet

2. Enter the name of the server and the URL and click Add. The Server will appear in the source list on
the left.

Procedure 3.10. Removing a WMS Server

When you have the WMS Server sheet visible, you can remove servers from the source list on the left

1. Select the name of the server from the source list on the left

2. Click Remove (-) beneath the source list

Procedure 3.11. Editing a WMS Server

When you have the WMS Server sheet visible, you can edit servers from the source list on the left

1. Select the name of the server from the source list on the left

2. Click Edit… beneath the source list

3. Change the name of the server and/or the URL and click OK

3.9. Adding Live Maps
One of the biggest challenges in GIS is putting data in context. In Cartographica, we provide access to a
number of Live Maps in order to make that process easier. Customers who have ongoing support and
maintenance agreements with ClueTrust have access to map data from Bing Maps®, and all copies of
Cartographica more recent than 1.2 have access to any service compliant with the OpenStreetMapTM
tiling URL pattern. Although the Live Maps are useful in many cases, it is important to remember that
Live Maps are not vector data, and thus can't be used directly for analysis, and they are only available
while the computer is connected to the internet.  In addition, take care with the coordinate reference systems,
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as they are generally considered quite inaccurate for precise measurements and comparisons of area and
distance. However, they provide an easy visual reference for presentation and basic checking of data.

Procedure 3.12. Adding Live MapBox Maps to Cartographica

MapBox access requires an active Cartographica maintenance license or a private MapBox key
to access data in Cartographica. To provide this key to Cartographica, paste it into the MapBox
Key (optional) box in the Cartographica Preferences window.

1. Choose File > Add Live Map….

The Add Live Maps Window appears.

Figure 3.9. Add Live Maps Window

The buttons on the left provide the selection among the different types of live maps: Bing Maps
(Microsoft-provided map data), MapBox (using MapBox-provided map data), OpenStreetMap (using
the main OpenStreetMap server), and Other OpenStreetMap servers (add a user-provided URL).

2. Select MapBox as the Map Source

3. Select the imagery type from the MapBox menu, choosing Aerial Imagery, Roads, or Roads on
Aerial Imagery as desired

4. Click Add to add the Live Map data to your map.

Procedure 3.13. Adding Live Bing Maps to Cartographica

Bing Maps now requires a user-supplied key to access the service. To provide this key to Carto-
graphica, paste it into the Bing Maps Key (optional) box in the Cartographica Preferences
window.

1. Choose File > Add Live Map….

The Add Live Maps Window appears.

2. Select Bing Maps as the Map Source

3. Select the imagery type from the Bing Maps menu, choosing Aerial Imagery, Roads, or Roads on
Aerial Imagery as desired

4. Click Add to add the Live Map data to your map.
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Procedure 3.14. Adding OpenStreetMap™ to Cartographica

OpenStreetMap has specific terms of use [https://wiki.osmfoundation.org/wiki/Terms_of_Use].
Please read and understand those before making use of OpenStreetMap live layers in Cartographica.

1. Choose File > Add Live Map….

The Add Live Maps Window appears.

2. Select OpenStretMap as the Map Source

3. Click Add to add the Live Map data to your map.

Procedure 3.15. Adding other OpenStreetMap-format layers to Cartographica

1. Choose File > Add Live Map….

The Add Live Maps Window appears.

2. Select Other OpenStretMap Server as the Map Source

3. In the Other OpenStretMap Server box, paste the URL or URL format string of the server that you
want to use. See Section 3.9.1, “Creating Appropriate OpenStreetMap URLs” for details on formatting

4. Click Add to add the Live Map data to your map.

3.9.1. Creating Appropriate OpenStreetMap URLs
Cartographica is flexible in how it ingests data from OpenStreetMap style tiling server, and thus can
communicate with more servers than just ones that are explicitly marked as OpenStreetMap.

In order to be compatible, the map tile server must serve up tiles in the WGS 84/Pseudo-Mercator coordinate
reference system (used also by Google Maps and Bing Maps.

If the server uses an OpenStreetMap URL format (z/x/y in tile coordinates), then the base URL may be
added directly (for example, OpenStreetMap would be https://a.tile.openstreetmap.org).
 If not, special codes may be added in the URL to delineate the positions of each of the tile coordinates.
 In these cases, you may put {x}, {y}, and {z} (or {zoom}) to represent each of the coordinates.  For
example, ArcGIS servers commonly are of the form:

http://myserver/ArcGIS/rest/services/MyMapLayerName/MapServer/tile/{zoom}/{y}/{x}

whereas some other server use explicit denotation and separators, such as:

https://mymapserver.com/foo/x={x}&y={y}&z={zoom}&scale=2&s=Ga

Either of these forms are acceptable to Cartographica

3.9.2. Printing and Publishing Considerations
As with all data that is presented on maps, you must take care to appropriately cite and honor the rights of
the originating entity.  In the case of OpenStreetMap, the data is explicitly open data, and as such the data
itself is available under the  OpenData Commons Open Database License
[https://opendatacommons.org/licenses/odbl/] (ODbL).  The tiles themselves are released under the  Creative
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Commons Attribution-ShareAlike 2.0 license [https://creativecommons.org/licenses/by-sa/2.0/]. Please
refer to these when you consider publishing your data.

Bing Maps data is under copyright to Microsoft and it is important to verify your eligibility before using
these in printed materials. Since ClueTrust no longer provides access to Bing Maps, you should consult
your license if you need to print or incorporate Bing Maps data into output.

MapBox map images are under copyright to MapBox and possibly other providers. Please see the MapBox
Attribution documentation [https://docs.mapbox.com/help/getting-started/attribution/#how-attribution-works]
for further information about appropriately citing MapBox data.

3.10. Importing Vector Data with WFS
Servers that support the Web Feature Service [https://www.ogc.org/standards/wfs] (WFS) specification
from the Open Geospatial Consortium [https://www.ogc.org/] (OGC) provide access to vector feature data
over the internet. Although the protocol has been around for some time (it's been implemented in Carto-
graphica and CartoMobile for a number of years now), it is not as popular as other online map format ser-
vices, such as Web Map Service (WMS), Web Map Tile Service (WMTS). However, it has a unique feature
that it actually provides geometric data instead of just visual representations.  As such, the geometric fidelity
and associated information can be substantial.  In addition, there is a writable version of the service (WFS-
T, Web Feature Service-Transactional) which can be used to write data back to the server.  Although
Cartographica does not support WFS-T as of this writing, CartoMobile does support it as a mechanism for
implementing remote data collection.

Cartographica considers WFS to be a data source, but locally caches information retrieved from the server
so that it can be used offline.

Procedure 3.16. Acquire data from a WFS Server

Acquire feature data over the internet from a OGC-compliant WFS Server

1. Choose File > Add Web Feature Layer….

The Add Web Feature Layer sheet appears

Figure 3.10. Add Web Feature Layer Sheet

2. Type or paste the URL for the WFS server into Server URL

3. Type or paste the name of the chosen layer into Layer

4. Click Add
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Cartographica will add a layer to the Layer Stack with the name of the layer and will retrieve the in-
formation from the WFS server. If the server is unavailable or requires a password, you will be
prompted for any supplemental information.

Procedure 3.17. Editing Existing WFS Layers

It is possible to change the parameters for an existing WFS layer. To do so:

1. Choose Layer > Web Feature Layer Attributes….

The Add Web Feature Layer sheet appears with the current data pre-filled

2. Change parameters as desired

3. Click Save

the filter is re-run and any new items are added to the local copy of the layer. It's important to remember
that existing features are not deleted, so you will have to manually remove them if you want them
taken out of the layer

3.10.1. Filtering data from a WFS Server
There are times when a WFS layer contains a combination of relevant and irrelevant data. In those cases,
the Filter box in Add Web Feature Layer can be used to limit what is downloaded from the server. The
form of the filter is an expression that is evaluated by the WFS server and can be pretty esoteric. It is sug-
gested that if you want to filter the information, you coordinate with your WFS server administrator or
consult the documentation for the provided layers in order to determine the format and function of the filters.
Some examples follow.

Example 3.1. Filter by property

<ogc:PropertyIsGreaterThan>
    <ogc:PropertyName>DATE_</ogc:PropertyName>
    <ogc:Literal>'2012-09-15'</ogc:Literal>
</ogc:PropertyIsGreaterThan>

This filter looks for features that have property that is named DATE_ which is greater than 2012-09-15.
The formatting needs to be precise and Cartographica will validate it with the server, so that you can make
changes and re-submit if necessary.

Example 3.2. Filter by property

<ogc:And>
    <ogc:PropertyIsGreaterThan>
        <ogc:PropertyName>DATE_</ogc:PropertyName>
        <ogc:Literal>'2012-09-15'</ogc:Literal>
    </ogc:PropertyIsGreaterThan>
    <ogc:PropertyIsEqualTo>
        <ogc:PropertyName>SOURCE</ogc:PropertyName>
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        <ogc:Literal>BIC</ogc:Literal>
    </ogc:PropertyIsEqualTo>
</ogc:And>

This more complex filter builds upon the previous filter and also requires that the SOURCE property be
equal to BIC. Note the use of the outer And command to dictate that feature match both conditions. You
could also use an Or here to dictate that matching either condition be matched. The specific operators
available may vary by server, but they generally take the same form and are always represented by XML.
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Chapter 4. Exploring Data
Cartographica is first and foremost a tool for exploration of data. This chapter describes many of the tools
available for visualizing the data that you have. In concert with the analysis and presentation features, these
tools provide a robust starting point for understanding the information within your data.

4.1. Zooming In and Out of Maps
There are several ways to zoom in and out of a map:

• Use the scroll wheel on the mouse while holding down the Option key on the keyboard
• Use the Zoom Dial on the right side of the Map Windows
• Use the Zoom To menu items in View to jump to particular zoom levels
• Use the zoom tool to zoom to points or areas using the mouse pointer
• Use the Previous and Next Extent items in View move to the previous or next zoom locations

Figure 4.1. Zoom Dial

Click and hold the zoom dial and move it up to zoom in and down to zoom out.
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You can also zoom by clicking your mouse when you are using the Zoom tool. The Zoom tool also has a
toolbar icon looks like this:

When the Zoom tool is selected, the cursor becomes a small little magnifying glass. Click anywhere in
the map to zoom in and center the map on that point. To zoom back out, click while holding the Option
key on your keyboard.

You can also zoom by selecting an area with the mouse (like drawing a box around it) when you have the
Zoom Tool toolbar icon selected. You will zoom in to the borders of the box you just drew.

To go to the last Zoom use the Previous Extent/Next Extent menu options available in the View menu.
Essentially, these options are undo/redo for zooming.

4.2. Selecting Data and Using the Identify Tool
The Identify tool allows you to draw around an area of features on the map or click one feature directly
and make the data about that feature appear in the data window. The Identify tool toolbar icon looks like
this:

Use the Identify tool to identify any feature in the currently selected layer. When you select the feature
by either clicking on it, or surrounding it with a rectangle that you can draw (also good for selecting multiple
features) the chosen items are highlighted in the data window.

For additional information display, Choose Window > Selection Info to display the Selection Info window,
which displays a scrolling list of information about each selected item. This is particularly useful if you
have a lot of items selected which aren't next to each other in the data view, or if you have closed the data
view to maximize map area.

FIGURE OF SELECTION INFO WINDOW

4.3. Using the Pan Tool to Move a Map
You can use the Pan tool to grab and move the map to change the view. The Pan tool toolbar icon looks
like this:

Once you have selected the Pan tool toolbar icon, the cursor becomes a small hand with which you can
move the map within the map window. Click the mouse at any point and then drag to move the map.

4.4. Data Tooltips
Data Tooltips show you summary information about selected features. By holding down the Option key
while moving over any item in the selected layer, a small window will appear with information about the
item you have moved over. The information that appears is defined in the Layer Info window.
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Further, if you prefer to have Data Tool Tips available at all times without having to hold the option key,
you can toggle them by choosing Map > Show Data Tooltips

Procedure 4.1. Specifying Data Tooltip information

1. Choose Windows > Layer Info to bring up the Layer Info Window.

Figure 4.2. Layer Info Window

2. Select the Fields tab to show the information about the columns

3. Check the Popup box on the line corresponding to the desired field.

The summary data is also used as the description information that is exported when using
the KML exporter.

4.5. Measuring Distance and Area
You can measure distances and areas using the Measure tool. The Measure tool toolbar icon looks like
this:

Once you have selected the Measure tool toolbar icon, you can use the mouse to measure distances and
areas. Any measurements you make appear in the Scale box , which appears when you begin your first
measurement.
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Figure 4.3. Scale Box for Measuring

In the Scale box:

• X and Y show the location (in map coordinates) of the mouse click (or just of the location of the cursor
if you are not holding down the button).

• X2 and Y2 show the location (in map coordinates) of the cursor if you are holding down the mouse
button.

• ∆X and ∆Y show the coordinate differences between X and X2, and Y and Y2 respectively (also in co-
ordinate units).

• Distance is the distance of a straight line from X,Y to X2,Y2 in linear coordinates.

• Area is the area of a rectangle bounded by "X","Y" and "X2","Y2" in linear coordinates. Essentially
the line you create is making the diagonal for a rectangle that is bound by those points.

"∆X" and "∆Y" are in linear or angular coordinates depending upon the coordinate system of
the map. However, distance and area are always in linear coordinates, using the great-circle
method when the coordinate system of the map is natively angular.

• Bearing is the bearing (relative to the X axis of the data) from X,Y to X2,Y2.

To change the units for the measurements, select one of the gear drop down menus in the measurement
window and choose the units. Units can be controlled and the scale itself may be restricted to a fixed size
(in units). When using fixed unit size, the units will be adjusted to the next larger unit if the value could
not be displayed in the available space.

Figure 4.4. Measurement Window Drop Down menu

To use the tool to measure distance:
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To measure a line or distance between two points, select the Measure tool toolbar icon. Click on the first
point from where you want to measure, hold the mouse button and drag the cursor to the second point. The
distance between those points will be displayed in the Measurement window.

To measure area, select the Measure icon, place the cursor over one boundary corner of the area you want
to know and then click and hold the mouse button down until you drag the cursor to the other boundary
corner of the rectangle you want to measure. The area of the rectangle appears in the Measurement window.

4.6. Using the Data View
Most GIS data has geospatial information in the form of features (points, lines, and polygons) and non-
geospatial data, which may consist of just about anything you can imagine: place names, number of crimes
in an area, type of pavement on road. This data is sometimes displayed on the map as labels, represented
by colors, or visualized in other ways.

The data view is located at the bottom of the main Cartographica window. This is a standard Mac OS X
table, and works the same as other tables on the platform.

Figure 4.5. Data View

The layer that is shown in the data view is the layer that is currently selected in the layer stack. If you are
looking at the screen and wondering why the data you're looking for is not what you expect, check the
layer stack and make sure the layer you are interested in is selected. If you have more than one layer selected
in the layer stack, no data will be shown in the data view.

Further, the selection in the data view is synchronized with the selection in the map view, which means
that if you select a feature in the map view, the data view will scroll such that the information about that
feature is visible. Similarly, if you click on a row (or rows) in the data view, the corresponding map view
features will be selected.

Procedure 4.2. Sorting the Data View

1. Click on the heading for the column on which you would sort the view

The table will sort to your specifications and an arrow will be displayed at the right side of the header
to indicate the sort order.

2. To sort in the opposite order on the same column, just click again in the column heading.
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Procedure 4.3. Re-ordering columns in the Data View

• Click on the column heading and drag it to the new location

The column will move from its old location to the new location

Procedure 4.4. Editing data in the Data View

Editing most of this data is very straightforward as it is done directly in the data table below the main Map
in the Map Window. Once you have a layer selected, click on the individual cell of data and start typing.

1. Select a single layer in the layer stack

Cartographica will display the data for this layer in the data view

2. Select a feature:

• Click on a feature in the map

• Click on a row in the table

The feature will be selected in both the map and the Data View.

3. Click in the column to change

The blue focus box will show up around the table cell indicating that you may now enter your data

Columns which have been locked or which contain Column Formulas cannot be edited and
will not enable when clicked.

4. Press the enter key to finish editing

Procedure 4.5. Locating the selected data on the map

There are times, especially when working with the Data View that you can't easily locate the data you have
selected on the map. Cartographica has a couple of different ways to view these.

1. Select the item that you want to locate on the map using the Data View

2. Locate the feature corresponding to the row:

• Tap and hold the space bar

The selected feature(s) will appear zoomed out to the full size of the Map View. When the space
bar is released, the feature will recede slowly into its position on the map. This is most useful
when you just want to locate, but not move the focus of the map

• Choose View > Zoom to Selected Feature

The Map View will be zoomed to an area encompassing the selected feature(s). This is most
useful when you are interested in seeing the detail of a feature.

3. Click on the heading for the column on which you would sort the view

The table will sort to your specifications and an arrow will be displayed at the right side of the header
to indicate the sort order.
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4. To sort in the opposite order on the same column, just click again in the column heading.

Procedure 4.6. Re-ordering columns in the Data View

• Click on the column heading and drag it to the new location

The column will move from its old location to the new location

4.7. Adding, Removing, and Renaming Columns
Columns may be added to and removed from any layer. There are some restrictions on exactly how this
is done.

Table 4.1. Column Change Restrictions

RestrictionsLayer Type

Columns added to By Reference layers will require
either internal saving or updating the original file to

All By Reference Layers

keep their data. This only happens when you save
the Map Set, so if you are doing this temporarily
there is no harm. The only exception to this are For-
mula Columns, which are only stored in the Map Set
and can continue to use the By Reference data.

Columns added to WFS Layers will not create new
columns on the server. Any data that is added to these

WFS Layers

layers will be lost when the Map Set is saved and re-
opened. As with By Reference layers, Formula
Columns will have their data recomputed on load
and thus will not be lost when saving a Map Set.

There are no features and thus no columns for Live
Maps.

Live Maps

Columns of any data type may be added in Cartographica. By default, the Add Column command from
the Layer menu will add a String column, which can represent textual or numeric data.

Procedure 4.7. Adding Columns to a Layer

1. Select the layer in the Layer Stack

2. Choose Windows > Show Layer Info to bring up the Layer Info window

3. Click the Fields tab to show the list of columns

4. Do one of the following:

• Click +

• Choose Layer > Add Column

A new column will be added to the column list and brought into view

5. Optionally change the type of the column by selecting from the corresponding Type cell
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6. Optionally change the size of the column by clicking in the corresponding Length cell

Procedure 4.8. Removing Columns from a Layer

1. Select the layer in the Layer Stack

2. Choose Windows > Show Layer Info to bring up the Layer Info window

3. Click the Fields tab to show the list of columns

4. Select the column to remove

5. Do one of the following:

• Click -

• Choose Layer > Remove Column

The selected column will be removed from the column list

Procedure 4.9. Renaming Columns in a Layer

1. Select the layer in the Layer Stack

2. Choose Windows > Show Layer Info to bring up the Layer Info window

3. Click the Fields tab to show the list of columns

4. Select the column to rename

5. Click in the corresponding Name cell and type the new name

The selected column will be renamed

4.8. Using the Selection Window
The Selection Window shows information about the features you select in the data window. To access the
Selection window, go toWindow > Show Selection Info.

Figure 4.6. Selection Window
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The Selection Window is best used for looking at specific data when you have multiple items selected in
the map or data view.

The left-hand side controls what information is available in the right-hand side. By double-clicking on the
left hand side, the Data View and the map view window will change to show only those items selected in
the column on the left-hand side.

4.9. Using the Point Data Window
The Point Data window is used for looking at the detailed geometric data of a feature. To open the Point
Data window, choose Window > Show Point Data.

All data in the Point Data window is expressed in the original coordinates. Modifying geometric points
will cause those points to be reprojected onto the current map's coordinate system.

Generally, it is easier to edit if Maps and Layers are (at least temporarily) set to the same value.

Figure 4.7. Point Data Window

Use the left side of the window (Part) to select the part within the feature (many features have only one
part, but others may have many). The right side of the window (Point) shows the list of points in the selected
Part. In the case of a Line, a part describes disjoint line segments. In the case of a Polygon, the parts describe
islands or holes in the Polygon.

4.10. Additional Layer Info
From the Layer Info Window click the Info Tab. The Info tab appears.
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Figure 4.8. Layer Info Window - Info Tab

The Info tab displays some additional information about the Layer.

Representing This pop-up menu describes the information that this layer represents. This
serves only as a guide for the software and for users.

Feature Name This pop-up determines which column in the data for this layer is used as the
feature name during display. This affects certain output formats (such as KML)
which have use for a name field and is displayed in Data Tool Tips.

Geometry Describes the type of features represented in this layer. Possible values are:
Point, Polyline, Polygon, Image.

Objects Provides a count of the number of features in this layer.

Points Provides a count of the number of points in all features in this layer. This is a
rudimentary measurement of complexity.

Bounding Box Shows the upper left and lower right coordinates of the bounding box in map
coordinates.

Base Bounding Box Shows the upper left and lower right coordinates of the bounding box in layer
coordinates.
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Chapter 5. Working With Layers
5.1. Using the Layer Stack

The Layer Stack appears on the left side of the Cartographica Window. This view shows all of the different
layers of data that appear in the map.

Figure 5.1. The Layer Stack

The Layer Stack defines what appears in the Map View and Data View.

You can drag items to re-order them in the layer stack. Top is "on top" if you were to think of it as a layer
cake or a set of papers layered on top of each other. Often, if you are using a raster layer, you'll drag that
to the bottom so that all the vector content sits "above" it.

You can also drop a layer on another layer to copy styles from the dropped layer to the dropped-on layer.
Although it might seem strange, you can also drop a layer on another layer of a different type. This allows
for an easy way to copy the color schemes.

Procedure 5.1. Showing and Hiding layers

• You can choose which layers are shown on the map by doing one of the following:

• Toggling the box next to the layer name in the layer stack

• Choose Layer > Hide Layer or Layer > Show Layer

When you do hide a layer the features contained in this layer are no longer seen on the Map.

5.2. Using the Layer Info Window
The Layer Info window shows the data features of the layer that is selected. It is used to add/remove
columns, change data types, and modify column names. To access the Layer Info window, choose Win-
dow > Show layer Info. The Layer Info window appears showing the Fields tab.
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Figure 5.2. Layer Info Window - Fields Tab

The Layer Info window is a live window, so you can make changes to the layer by editing the values in
it. Here is a description of each of the columns in the Layer Info window and their purpose.

Table 5.1. Layer Info Window Columns

name used by the Data View and the Legend, and
has very few practical limitations, other than needing
to be unique.

Display Name

Type of the data in this column. This determines how
the data in the column is to be interpreted by Carto-

Type

graphica. Possible types are: String, Float, Number,
Boolean, and Date. 

The storage length for this column. This will determ-
ine the maximum length of a string, the maximum

Length

number of digits of a Number column, etc.  Float,
Date, and Boolean should be left at the system sug-
gested values.

For the Number column (fixed digits), this is the
number of digits of the Length field that are dedic-
ated to numbers after the decimal point.

Precision

If this is checked, this column is used in the Pop-up
preview (for example, if you hover over a feature)

Pop-up

Determines if this field is locked. This is mostly used
with the calculated formulas (see Column Formulas)

Lock

columns, as it will prevent these from being re-calcu-
lated.

This is the actual data storage name internally.
 Generally, you're better off not to change these un-

Field Name

less you know you're going to be re-exporting SHP-
file data and you need to match column names with
other software.
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For example, to change the Display Name (the name that shows up in the Data View) for ACTUAL_E,
click on the word and then type a new name. Similarly, the length, precision, and type of data can be ma-
nipulated by making changes to those columns.

If you change a column's type, Cartographica will attempt to coerce the data in that column to the
new type, but that may not always be possible. Take particular care when converting textual data
to numbers, as you are likely to end up with many 0's if the data cannot be reinterpreted.

5.3. Filtering on Layers Using the Filter Box
You can use the Filter Box from the main window to filter map data within a layer and to create new data
layers with the results. The Filter Box appears in the top right of the main Cartographica window.

Figure 5.3. Filter Box

Enter the data you want to filter into the search box. As you type, the results are narrowed and are displayed
(filtered) in the data window. This filter is extremely fast, even for large datasets and is the preferred
method for finding an item in the data window. Use the Filter Box with Layer/Create Layer from Selection
from the Layer menu to split off data that is interesting for further analysis. The filter operates on the layer
currently selected in layer stack. The filter works by filtering the data in the selected layer as shown in
both the data and map views. You can also use extensions such as commas to further filter results.

And/or and multiple-field data filtering is now possible and easy with this new system. The existing filter
box works as a short-cut, translating queries into the new system, which can then be edited.

As you type into the filter box, you will see a drop-down area at the top of the Map View that contains a
much more flexible filtering system.

Figure 5.4. Advanced Filter Box

You can select which filter or all filters to use by selecting either Any, All or None of the following are
true.

The first selection drop down menu (shown as info.Capital in the screen above) is a menu to select which
column in the data window you want to search.

Then you can select if you want the filter to be is the less than, is greater than, or is, or contains the filter
phrase.

The text box contains the text you enter that you want to filter on.

You can click the + or - button to add or remove additional filters.
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Click the Done button to dismiss the additional Filter boxes and restore the maps and data views to allfeatures
in the selected layers.

You can also filter using variables from the same or multiple fields. This is useful for creating new layers.

5.4. Adding and Removing Layers
Although most layers are added to Cartographica map sets by importing them from existing files or network
services, it is quite reasonable to create a layer yourself. Most frequently the goal of adding a layer is
manually create some new features (such as drawing an area over an existing map).

Procedure 5.2. Adding New Layers

1. Do the following to create a new layer:

• Choose Layer > New Layer

• Click on the Add(+) button under the Layer Stack

The new layer is added with no data and the a default name

2. Click on the name in the Layer stack to select the text and then replace with your new name

Procedure 5.3. Removing Layers

1. Select the layer you wish to remove in the Layer Stack

2. Do one of the following to remove the layer:

• Click on the Remove(-) button under the Layer Stack

• Choose Layer > Delete Layer

The selected layer is removed

5.5. Adding a New Layer Based on a Data Selec-
tion

If you want to create a new layer from a selection of data in your map, select the data you want to add to
a new layer in the Data window. Now, Layer > Create Layer from Selection.

You can also select a data set using the filter bar to create a filtered list of data to create a new layer from.

This creates a new layer that will appear in the Layer stack from the selected features in the current layer,
copying the styles and all data attributes.

5.6. Merging Layers
Cartographica can merge layers with similar data into a single layer, creating a new layer with the contents
of all the selected layers, and removing the original layers.

This is commonly used to put like data together in a single layer for easy manipulation.
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Consolidating layers will remove all of the selected layers from the map and replace them with a single
layer that has all of the features of the selected layers.

• Layers must contain the same kinds of features (points, lines, or polygons).
• Layers with different dimensionality (2D, 3D, or 4D) will be upgraded to the highest dimensionality of

the set.
• Optionally, you can choose to consolidate data fields for layers containing columns of the same name

by clicking the Consolidate data fields with the same name checkbox. Columns with different names
will be appended and the data for the other features will be left blank.

Procedure 5.4. Merging Layers

1. In the Layer Stack, select the multiple layers you want to merge, by command-clicking the mouse on
each layer.

2. Layer > Merge Selected Layers.

The Merge Selected Layers dialog appears.

Figure 5.5. Merge Selected Layers

3. If you would like to add a column to each entry in the new layer stating which layer the entry originated
from, click the Add original layer name in From Layer field checkbox.

4. Choose which Layer the styles come from using Inherit styles from drop down box.

5. Now click Consolidate.

5.7. Masking Data for Analysis Layers
When using an analysis layer (for now only created by the Kernel Density Map), often the analysis layer
has a significant amount of data falling "outside" of the area of interest. To help remedy this, Cartographica
can constrain the bounds of the analysis layer to the area of a polygon layer.

Below are examples of an analysis layer, the mask to be applied, and the resultant masked analysis layer.
In this case, we use a Kernel Density Map and have a satellite map in the background as illustration.
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Figure 5.6. Analysis Layer without Mask

Figure 5.7. Analysis Layer Mask

Figure 5.8. Analysis Layer with Mask

Procedure 5.5. Masking an analysis layer

In order to mask an analysis layer, you need to have a polygon layer that specifies the area you want included
in the analysis. You can either use an existing polygon layer, or create one manually or using tools such
as Cartographica's Tools > Make Convex Hull

1. Select the analysis layer in the layer stack by clicking on it

2. Select the polygon layer in the layer stack by holding the option key while clicking on it

3. Choose Layer > Set Mask Layer

After a few seconds, the analysis layer will be masked by the polygon layer you selected.

The mask layer will work even if the mask layer is hidden, so you can add a layer to act as
the mask, assign it to the analysis layer, and then hide the mask layer without losing the mask
effect, but without having whatever data is in that layer displayed.
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Procedure 5.6. Removing an analysis layer mask

1. Select the analysis layer in the layer stack by clicking on it

2. Choose Layer > Clear Mask Layer

5.8. Setting Layer Projection
In the event that a layer of data is imported without any projection information, Set Layer Projection can
change the projection without modifying the data.

It is common for data that comes in csv form to be delivered in a State Plane Coordinate System instead
of Latitude/Longitude (which will be automatically selected in most cases). In the case that the projection
information is not there, use the following process to set the layer projection.

1. Layer > Set Layer Projection to set the layer's projection information.

The Set Projection Layer dialog appears.

Figure 5.9. Set Projection Layer Window

Setting the projection here will change the projection for this particular layer, but it will not change the
shape data. Changes will be saved in the map file and possibly in an associated PRJ file.

2. From the left side of the dialog, choose the map projection that best suits your needs.

The Description box on the right will change depending which projection is selected. You can also click
the Specifications tab to see additional details about the selected projection.

Below this informational area there is a small preview area that gives a general orientation for the features
of your map once the selected projection has been confirmed.

Here you should use the filter box to search for a projection.
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The feature projection shape is previewed on the right side of the window so you can get an idea of
what the selected projection will look like.

3. Once you have the selected the projection that best suits your needs and most accurately represents the
data you are attempting to display, click Set.

5.8.1. Reprojecting Layers
Cartographica allows users to change the geographic projection of data to several predefined datums. The
limited applications include preparing data for export in another CRS.

For example, if you need a shape file in WGS84, but you have data in State Plane, you can use Reproject
Data to change the data from the State Plane to WGS84 and then use the Export Layer command to export
it.

This is seldom the case, so most often, you can use Map > Project Map to set the map projection
or Layer > Set Layer Projection to change how the features in a particular Layer are interpreted.

To permanently change the map projection:

1. Layer > Reproject Layer.

The Reproject Layer dialog appears.

Figure 5.10. Reproject Layer dialog

Changing the projection here will permanently modify the shape data to correspond to the selected
projection. If you reconvert it back to the original, it is likely that a loss of accuracy will occur. If you're
not certain you want to do this, set the projection.

2. From the left side of the dialog, choose the map projection that best suits your needs.

The Description box on the right will change depending which projection is selected. You can also click
the Specifications tab to see additional details about the selected projection.
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Below this informational area there is a small preview are that gives a general orientation for the features
of your map once the selected projection has been confirmed.

3. Once you have the selected the projection that best suits your needs and most accurately represents the
data you are attempting to display, click Set.

5.9. Referenced Data
Cartographica tries to be intelligent about referencing external data in order to maximize efficiency and
convenience. In many cases, Cartographica can make an external reference to a file instead of making it
part of the Mapset. This data is referred to as being Externally Referenced.

When a layer is Externally Referenced, it has a by reference icon in the layer stack on the right side. Also,
when that layer is selected, the Layer menu's Include Layer Data in Mapset item is unchecked.

Often, storing boilerplate data and large imagery in external files is desired to save space and to make up-
dating that data easy. Imagine having a set of 10 maps that all need road information, but your road inform-
ation changes on a monthly basis. If your road polygons are kept in an external file, you need only update
the external file, load your mapset and the information is up-to-date.

The main reason to use this is if you need to "Freeze" the data for a particular layer so that you don't acci-
dentally change it.

Procedure 5.7. Bringing External data into the Mapset

1. Select the desired layer from the Layer Stack

2. Choose Layer > Include Layer Data in Mapset to bring the data into the Mapset. The next time
you save, a copy of the data will be made inside of this Mapset.

Once a data set it brought into the Mapset, the only way to make it external again is to delete the layer with
the internal copy and re-import the data.

Occasionally, you may need to create a copy of a Cartographica Mapset for distribution to other parties or
to archive the complete state of a map and all its constituent parts. In this case, often it is necessary to put
all of the data into the Mapset file before sending it because the recipient may not have the original files.
Since permanently changing this might not be desired, you can save a copy of your Mapset file that has
had all of its layer data brought internal, or "flattened".

Procedure 5.8. Flattening a Mapset

1. Choose File > Save As to begin the saving process

2. Check Flatten Map When Saving to flatten the file

3. Now choose a file name and click Save

56

Working With Layers



Chapter 6. Working With Styles
Styles determine how a map looks when viewed, printed, embedded in a map layout, or exported to any
style-conscious format (such as Adobe Illustrator or KML).

Cartographica has a sophisticated style system which provides significant control over how data is shown
on the screen and in printed output.

Styles are assigned and manipulated for each layer individually.

Procedure 6.1. Opening the Style Editor

To bring up the Style Editor for any layer, use one of the following techniques:

1. Select the desired layer in the Layer Stack

2. Open the Style Editor:

• Double-click on the layer to open the Style Editor

• Click on the Styles… button at the bottom of the Layer Stack to open the Style Editor

• Choose Layer > Show Layer Styles

At this point, you should have an appropriate Style Editor Window visible.
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Figure 6.1. Layer Styles Window (showing a complex polygon layer)

6.1. Styling Vector Layers
Styles in Cartographica are a very powerful mechanism for changing the presentation of your map. By
using the values of data in the features, Cartographica can create thematic maps without requiring manual
intervention in every step of the process.

When Cartographica prepares to draw a particular feature, it first evaluates the style, as defined in the
layer's Style Window, to determine if the feature qualifies for a particular style variation, or if it is to be
drawn with the Default Style. For layers where you desire all features in the layer to look the same, use
only the default style and all features will be drawn the same.

Vector styles share many traits, although each different type of feature (lines, polygons, and points) have
some unique attributes and slight variations in how the standard attributes are applied.

For all style manipulation, work begins in the Style Window.
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Figure 6.2. Style Window (displaying a complex point style)

The style window is divided into three primary areas:

• The upper left portion of the window contains the Style List, which is used to discriminate between
styles in a style set. All layer styles can either be comprised of a single style (in this case, referred to as
the Default Style) or multiple styles. This will be covered later in Section 6.1.5, “Complex Styles”.

• The right side of the window is the Appearance pane and it determines how each feature in a particular
style looks. This includes the label, marker, lines, colors, and naming.

• The lower left portion of the window is a Preview of the style you are currently working on. In the case
of multi-style style sets, the selection in the Style List determines which style is shown in the Preview.

Since many of the elements of the Appearance pane are common to every feature type, we will examine
what each element represents and how it is used, going from the top to the bottom.

• Name is used in the Map Legend and other areas of the software to represent this particular style in a
style set. The contents of this field are used as the name of the style in the legend, when multiple styles
are shown. If you leave the Name field empty, Cartographica will create defaults based on the values
that comprise the style's range.

• The color wells are used to adjust the color of individual elements. Their use varies based on the type
of features represented by the layer, and by the element that is being styled. Color wells function as drop
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targets and bring up the color picker when they are clicked on, allowing you to choose colors using the
standard mechanisms available to all Macintosh software.

• Size fields are denoted by a slider and a text area and allow you to change size parameters, such as line
width, pattern size, or symbol size. The slider and the box both provide the same control, and you can
use them interchangably.

• Item Label and Insert Field menus are used to determine what text should be placed next to the point,
along the line, or inside the area. You can add text to the label by typing into the box, and references to
fields can be added by placing the cursor where you want the field and then using the Insert Field pop-
up menu to select the field you want added. A field marker (with the name of the field inside of a colored
cell) will be placed at the cursor location. This is covered in depth in Section 6.1.4, “Labeling Features”

• Always show labels determines if labels are always shown for this particular style, or whether the system
should determine whether they should be visible or not. Generally, you should leave this unchecked for
most styles, but if you have features whose labels you always want displayed, this box provides allows
you to override that.

• Symbol, Picture, and Picture Path are only available when editing Point features, and so they will be
covered in Section 6.1.1, “Point Styles”.

6.1.1. Point Styles
Point styles can be customized in many ways. The Size slider and box control the total size of the point
item. Due to variations in particular symbol drawing techniques and different visual weights (which affect
apparent size), it is often the case that symbols with the same size are similar, but not identical in size or
area. This is to be expected. We have tried to keep the sizes consistent for all symbols created directly inside
of Cartographica, but you may need to balance sizes a bit, especially when using custom picture- or font-
based symbols or when using symbols of greatly differing weights.

For most Point symbols, the Stroke box and color well determine if the outline of the symbol is visible
and the color of the symbol outline. Not surprisingly, the Fill color well determines the color which fills
in the symbol. For some symbols, there is no "fill" area, and therefore the symbol's fill color does not
matter and the stroke must be present for the symbol to draw. Examples of these in the built-in symbols
are the cross and plus.

Although Cartographica may not ship with the variety of symbols of some other programs, the ability to
import high-resolution symbols from a variety of places makes up for many missing symbols. To change
a symbol, the Symbol Well is used as the dropping point for one of a variety of sources:

• The Symbols Browser window, which is the built-in repository for scalable symbols (pictured in Fig-
ure 6.3, “Symbol Browser Window”), contains a number of common symbols for use on maps which
are simple, but highly scalable.

• Images from a variety of sources. Basically any image that you can get onto your Macintosh is usable
as a symbol in Cartographica. This can be a graphic from a web page, something designed in illustrator,
or a licensed piece of clip-art. When an image symbol is used, Cartographica pays attention to the alpha
channel for transparency, meaning that transparent-capable formats such as PNG are more desirable
than JPEGs, as an example.

When using images as symbols, the Stroke and Fill colors can seem to behave oddly. This is
because, when checked, the Stroke will color anywhere in the image that is not transparent,
and the Fill will not be used. For graphics that have transparency, this can have the desirable
effect of being able to color the parts of the image with color. However, for graphics that contain
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black and while colors (for example), it has the surprising effect of coloring the entire symbol
(white and black) with the stroke color. To turn off the color manipulation, just uncheck Stroke.

• The Macintosh Character Viewer. The Character Viewer is a standard part of OS X, which is made
visible on the screen by checking the Show Keyboard & Character Viewer in menu bar option in
the Keyboard preferences panel in System Preferences. Once this box is checked, you can bring up the
window by choosing Show Character Viewer from the menu bar. Any character from the palette can
be made into a Cartographica symbol just by dragging it into the Symbol Well. Among the available
symbols in many standard fonts are: airplane, a variety of stars, and many more. Plus, cartographic
symbol fonts are also available from a variety of commercial and non-commercial providers.

• Stylized text from any window. Although single-characters are often enough and our labeling system
provides ample opportunity to provide static and variable text labeling, text from any window can also
be used as a "symbol" for a point.

Besides symbols, Cartographica can also represent points with a picture stored on disk by using the Picture
check box and field selector and optionally the Picture Path to specify the location of the referenced pic-
tures. When using a picture to represent the points on the map, the Picture box must be selected and a
field must be chosen in the pop-up menu. The picture field designates which column contains the file name
of the referenced file, which can be a full or partial path name. A partial path name is resolved first by
looking at the Picture Path and then by using the directory the layer (or map set for an internally-stored
layer) is saved in as the default. When using a picture symbol, the Image Viewer will come up whenever
a represented point is selected, showing a larger version of the picture (or a playable version of the movie,
if the referenced data is a movie file).

Figure 6.3. Symbol Browser Window

Labels may also be added to point features, see Section 6.1.4, “Labeling Features” for further information.

Procedure 6.2. Setting the Symbol for a Point layer

1. Open the Style Editor for the desired layer
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2. Click once in the Symbol well in order to bring up the Symbol Browser Window.

3. Choose a symbol from the Symbol Browser Window and drag it to the Symbolwell

4. Adjust Point Size,Stroke, and Fill as desired

Procedure 6.3. Using a Font Character as a Symbol for a Point Layer

1. Open the Style Editor for the desired layer

2. Bring up a window containing the font character. Commonly this is done with the Show Character
Viewer item from the menu bar (if you can't find it, you may need to turn it on in the Keyboard
System Preferences

3. Choose a symbol from the character viewer or other window and drag it to the Symbolwell

4. Adjust Point Size,Stroke, and Fill as desired

Procedure 6.4. Using an Image File as a Symbol for a Point Layer

1. Open the Style Editor for the desired layer

2. Bring up a Finder window containing the symbol file

The file should be one of the standard image types understood by the MacOS X, such as:
PDF, Adobe Illustrator, GIF, JPEG, PNG, etc.

3. Drag the file to the Symbolwell

4. Adjust Point Size,Stroke, and Fill as desired

The effect of the Stroke and Fill on image symbols can be a bit strange. Generally, you will
want to use the Stroke box and color only if you want to completely fill the symbol with the
stroke color.

Procedure 6.5. Using Pictures as a symbol

Before using pictures as a symbol, you must make sure that you have the picture files in a format that
MacOS X understands, such as JPEG, GIF, or PNG. You must also know where those files are in relation
to the Picture Path or the layer data.

These instructions assume that you already know where the pictures are and have a column that contains
the partial or full path names to the picture files.

1. Open the Style Editor for the desired layer

2. Select the name of the column with the paths by using the Picture pop-up

3. If your photos are referred to by partial path names, you may need to select the Picture Path by using
the pop-up menu

4. If you would like the pictures to show up in the map as the Point symbol, make sure the Picture box
is checked
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To change the size of the displayed picture on the map, use the Point Size slider or box.

6.1.2. Line Styles
Line styles can be used to change the visual aspects of lines on a map. Some of the components for line
styles should now be familiar to you, based on the point styles, but lines have some additional attributes.

Line styles are based on a line style template, which are dropped into the line style well in order to assign
them to a style. In the example shown below, the Default Style for this line contains a line with thin black
strokes, and a yellow fill. Not all lines will have both parameters, however they should all have a Stroke
color, so that you can change the overall color of the line style. In some special cases, there are colors in
the style that are not able to be changed through this window. If you are using one of these styles and find
the need to change the color, look for another line style in the Lines tab of the Uber Browser.

The Width determines the width of the line, and in the case of a stroked line, the width of the stroke as
well. The two are proportionate, and therefore the width is a scaling factor that operates equally on each
of the components of the line.

Figure 6.4. Style Window (displaying a complex line style)
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Procedure 6.6. Setting the Line Style

1. Open the Style Editor for the desired layer

2. Click on the line style well next to the color wells

The Uber Browser will appear with the Lines tab selected.

3. Choose a line style from and drag it to the line style well

The line style should change in the well, the preview, and on the map to reflect your choice.

4. Adjust Size,Stroke, and Fill as desired

6.1.3. Polygon Styles
Polygon styles can be used to change the coloring, pattern, outline style, and labeling of polygon features
on the map. You can leverage much of your knowledge from the line and point styles to use the polygon
style window. In fact, the window is even set up to reflect this, with the Outline box in the top position
(where the Line box appears for lines), and the Pattern box in the lower position (where the symbol box
appears for poings).

When a polygon is drawn, Cartographica uses the Outline information to draw the outline of the polygon,
and the Pattern information to fill in the inside of the polygon.

The patterns in Cartographica work similarly to the Symbols in point layers. There are certain pre-defined
patterns that come with Cartographica, and they are made up of black and transparent data, so that they
can be scaled and colored easily. However, you can also use just about any image (including symbols from
the symbol tab) as fill for polygon layers.

When a pattern is not in use, the pattern well is empty (as is shown below), and there is a Fill color well
to determine the solid fill color to be used. When patterns are used, the pattern will appear in the pattern
well and Stroke and Size controls will be added, to control the color of the stroke, and the pattern size,
respectively.
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Figure 6.5. Style Window (displaying a complex polygon style)

Procedure 6.7. Setting an invisible line style

Sometimes it's necessary to have a polygon with no outer edge. In this case, you will need to remove the
line to prevent it from drawing.

1. Open the Style Editor for the desired layer

2. Click on the line style well next to the color wells

The Uber Browser will appear with the Lines tab selected. (This can be ignored for now)

3. Switch back to the style window

You should find that the line style well is highlighted, indicating it has keyboard focus

4. Use the delete key on the keyboard to remove the line style

The line style should disappear from the well, the preview, and on the map to reflect your choice.
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Procedure 6.8. Setting an invisible fill color

Sometimes it's necessary to have a polygon with no visible fill color. In this case, you need to remove any
pattern and set the fill color to transparent.

1. Open the Style Editor for the desired layer

2. Click on the pattern well next to the fill box

The Uber Browser will appear with the Patterns tab selected. (This can be ignored for now)

3. Switch back to the style window

You should find that the pattern well is highlighted, indicating it has keyboard focus

4. Use the delete key on the keyboard to remove the line style

Any pattern will disappear from the well, the preview, and on the map to reflect your choice.

5. Click on the Fill color well to select the fill color and bring up the Color window

6. Use the opacity slider to set the opacity of the fill color to 0%.

The well will be filled with a triangular symbol signifying you have a transparent color and color will
disappear from the preview, and on the map to reflect your choice.

Procedure 6.9. Using an Image File as a Fill Pattern

When Cartographica doesn't have the fill pattern that you need, you can specify the fill pattern using a file.
That file will be automatically tiled by Cartographica to fill the area.

1. Bring up a Finder window containing the image file for your pattern

The file should be one of the standard image types understood by the MacOS X, such as:
PDF, Adobe Illustrator, GIF, JPEG, PNG, etc. For best results for scaling, you will likely
want to use a PDF file, although images will also tile.

2. Drag the file icon to the Fill well

3. Adjust the Size, Stroke, and Fill as desired

The result of the Stroke and Fill on image fills can be a bit strange. Generally, you will want
to use the Stroke box and color only if you want to completely fill the symbol with the stroke
color.

4. Use the delete key on the keyboard to remove the line style

Any pattern will disappear from the well, the preview, and on the map to reflect your choice.

5. Click on the Fill color well to select the fill color and bring up the Color window

6. Use the opacity slider to set the opacity of the fill color to 0%.

The well will be filled with a triangular symbol signifying you have a transparent color and color will
disappear from the preview, and on the map to reflect your choice.
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6.1.4. Labeling Features
All styles can be labeled, providing a way to indicate the name or other attributes of a feature on the map.

Labels are among the most complex options in Cartographica due especially to the need to avoid clutter
and collision when items are placed near each other. Although the particular algorithm cannot be described
in detail and is subject to some amount of change, here are some important points to understand about how
Cartographica handles labels:

• All labels are drawn after all features are drawn and therefore labels show up "on top" of all features,
including those features above the features that are being labeled. This prevents problems such as the
label for a State (usually a polygon layer) being occluded by the point and label for a city in that state
(usually a point layer positioned above the polygon layer so that the features are visible).

• Labels are evaluated in layer order, which is to say that the labels of layers at the bottom of the layer
stack have a higher priority than those at the top of the stack.

• Within a layer, labels are evaluated in draw order, which is really not deterministic, and therefore there
is not a good way to tell which labels in a layer will be drawn a priori.

• The best way to control labels is to only turn them on for items that are important for display purposes.
This can be achieved by using a Complex Style (see Section 6.1.5, “Complex Styles”) to separate the
labeled and unlabeled items.

• When necessary, very complex labels can be made by using a Calculated Column (see Chapter 13,
Column Formulas) to create the contents of the field and referencing that calculated field in the label.

• Labels can have multiple lines, which are added by inserting a return in the Item Label box.

Labels are controlled by the content of the Item Label box, shown in close-up in Figure 6.6, “Label field”.
Labels can contain text and fields and can be styles using one or more fonts and sizes. The example shown
here is a simple label containing introductory text "Zip:" and the contents of the ZIP_CODE field. In the
Item Label box, the contents of a field are represented by a Field Marker, which is the name of the field
surrounded by a colored oval.

Field Markers may be moved around through drag and drop and may be copied, pasted, and deleted.

Figure 6.6. Label field

Procedure 6.10. Add a label to a style

1. Click in the Item Label box to move the text cursor there

2. Type the desired text in the box:

• Type text into the box to create an unchanging text label
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• Choose the desired field from the Insert Field pop-up menu to insert the field marker into the
labe.

6.1.5. Complex Styles
So far, we have been describing simple styles, which apply identically to every feature in a layer. However,
it is often the case that some features in a layer deserve special attention. Examples of this include a layer
that contains cities, some of which are state or country capitals, or a layer of roads that contains both local
roads and large highways. In each of these cases, some of the features in the layer are singled out for special
attention.

Complex Styles are also used when attempting to show quantitative or qualitative attribute information
graphically. For example, a polygon layer representing states could be colored differently based on popu-
lation; similarly, the size of a city symbol in a point layer could vary based on population.

There are three primary controls for complex styles: the Based on: pop-up menu, which is used to determine
which field is used to discriminate between the styles; the style list on the left side of the window above
the Preview box, which displays the list of defined styles and provides for addition, deletion, etc.; and the
Hide features that don't match check box, which determines whether the Default Style is used.

In complex styles, the Based on: pop-up menu determines which column of data is to be used for discrim-
inating between the styles. Once the column is selected, use the table on the left of the window to determine
the breaks for each style variant.

When using a string column to discriminate, you must use the Value column, which indicates an exact
match between the value in the column and the one you define in the style here. When using a numeric
column to discriminate, you may use either the Value column or the From and To columns. For the Value
column, the data must still match exactly. When using the From and To columns, the value must be
within the range specified. The Distribute button may be used to help create natural ranges based on a
linear distribution over the range of the data in the selected layer.

Under Based on are 3 pieces of data that appear when a column name is selected. These are the field type
(string, number, date), and the minimum and maximum values.

The table in the left of the window lists the values or ranges for each style in the style set. To change the
appearance of the style, select it in the table at the left and then adjust the parameters on the right, using
the techniques described previously for each feature type.

You may also select multiple styles at the same time, allowing simultaneous editing of items. This is useful,
for example, when using different symbols, but wanting to change the size for each of them. In this case,
select the desired styles and then change the size. The size will change, but the remainder of the appearance
will remain unchanged.

Styles are added to the list by using the + and - buttons, or by Edit > Duplicate or Edit > Duplicate and
Increment. The + button adds a new style by copying the default style. Each of the menu items provides
a way to add an identical copy of the selected style to the list, with the Duplicate and Increment also in-
creasing the From and To values.

When using quantitative information to discriminate between styles, it is often beneficial to have Carto-
graphica assign breaks between the styles. The gear menu provides access to these functions, as outlined
below:

• Distribute With Equal Intervals: distributes the values of the Based On: field across all of the styles
in the style list. For example, if the values range from 0-100 and you have 4 styles currently in the list,
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those styles are changed to range from 0-24,25-49,50-74, and 75-100 respectively. No other changes
are made to the styles and the number of styles are not changed.

• Distribute With Natural Breaks (Jenks): distributes the values of the Based On: field using the Jenks
natural breaks distribution method. This method will calculate the natural breaks that occur in the data
set, based on attempting to determine where clusters of values exist. No other changes are made to the
styles and the number of styles are not changed.

• Distribute With Equal Count: distributes the values of the Based On: field by making each range
contain an equal number of features. This is done using an increasing value, so the ranges will always
be contiguous. For example: 5-10,11-20,21-30, etc.

• Distribute With Equal Area (available only for polygon layers): distributes the values of the Based
On: field by making each range contain an equal area on the map, in the current CRS. This is done using
an increasing value, so the ranges will always be contiguous.

• Distribute With Quartile Distribution: distributes the values of the Based On: field into four (4)
groups by making each range contain an equal number of features. This is done using an increasing
value, so the ranges will always be contiguous. When applied to a style set, any existing styles will be
used up to the fourth one, and all styles beyond the fourth will be removed.

• Distribute With Quintile Distribution: distributes the values of the Based On: field into five (5) groups
by making each range contain an equal number of features. This is done using an increasing value, so
the ranges will always be contiguous. When applied to a style set, any existing styles will be used up to
the fifth one, and all styles beyond the fifth will be removed.

• Distribute Unique Values: distributes the values of the Based On: field into one group per value. This
is mostly for use with string columns, although numeric columns with a small number of actual values
can also be used. When applied to a style set, any existing styles will be used where possible, and all
styles beyond those necessary will be removed.

All style information updates immediately, both in the preview window and in the map view, so the user
should be able to drag the sliders and move around with the color picker until they have matched what
they need.

Procedure 6.11. Applying a palette of colors to a set of styles

It is often desirable to use a set of common colors for particular maps. Cartographica provides an easy way
to take a color palette and apply it to the fill or stroke color of each element in a style list in turn. The result
is a series of different colors, one for each style

1. Open the style window for the desired layer

2. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

3. Choose a color palette and drag it to the style list, dropping it when the cursor changes to the add
cursor.

To change the stroke color instead of the fill color, hold down the option key on the keyboard
when you drop the palette
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Procedure 6.12. Temporarily disable all styles for a layer

This method disconnects the discrimination logic, leaving every feature in the layer at default. No other
parameters are changed, so it can be used safely to "flatten" the appearance of a layer without actually
changing it's style.

1. Open the style window for the desired layer

2. Change the Based On value to None

None of the other settings for the style set will be changed by doing this, so you can change
back to your previous style settings just by returning the Based On pop-up to its previous
value.

Procedure 6.13. Hiding Features

When using complex styles, there may be times where you want to remove items that match a particular
criteria (or do not match any of the criteria) from the map. For this, Cartographica has the Hide these
Features option to hide features which match a particular category.

1. Open the style window for the desired layer

2. Select an existing style (or create one from above) which you want matching features hidden

Features matching this style will be hidden from output.

6.2. Styling Raster Layers
For raster layers, the styling is much simpler than for vector layers. Since the raster layer often contains
detailed color data, there is no real need for a complex system as with vectors.

For some raster layers, their content is a representation of data instead of imagery. In these cases, Carto-
graphica can be used to visually color the raster layer based on the values of data in the layer.

For both of these cases, you can adjust the opacity of the layer so that it may be placed above another layer,
mixing some of the contents of the underlying layer with the contents of the overlaid layer.

Although a number of color palettes are included with Cartographica, see Chapter 14, Color Palettes for
more information about using and editing color palettes.
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Figure 6.7. Raster Layer Styles Window

Procedure 6.14. Adjusting a Raster Layer's opacity

1. Select the layer in the layer stack

2. Choose Layer > Show Layer Styles to bring up the Raster Layer Style Window for this layer.

3. Drag the Layer Opacity slider to the desired opacity

The layer on the Map will update as you do this

4. Close the Raster Layer Style Window

Procedure 6.15. Changing a Raster Layer's palette

1. Select the layer in the layer stack

2. Choose Layer > Show Layer Styles to bring up the Raster Layer Style Window for this layer.

3. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

4. Select a new palette from the list and drag it to the Palette well in the Raster Layer Style Window

The layer color in the map should be updated immediately

5. Close the Raster Layer Style Window

If you are working with a true-color image (one with component RGB), the palette well will not
be available.
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6.2.1. Concentrating the palette representation
In some cases, the entire range of the data is not useful for visualization. This can happen, for example
when a data set contains mostly data in a small range, but has a few outlier data points that are the result
of errors in data gathering. It can also happen when the interesting range is a small fraction of the total
range of the data. Cartographica can visualize a smaller (or, in fact, larger) range of data values without
having to modify the underlying data by constraining the application of the palette to a different range of
values than those in the sample set. All values above the range and below the range are clamped to the
highest and lowest values respectively.

Procedure 6.16. Constraining palette range

1. Select the layer in the layer stack

2. Choose Layer > Show Layer Styles to bring up the Raster Layer Style Window for this layer.

3. Check Manual to enable using a manual range for the palette

4. Type new values into the Minimum and Maximum boxes to determine the specific range

5. Close the Raster Layer Style Window

Procedure 6.17. Setting automatic palette range

1. Select the layer in the layer stack

2. Choose Layer > Show Layer Styles to bring up the Raster Layer Style Window for this layer.

3. Uncheck Manual to use the automatic range

4. Close the Raster Layer Style Window

6.3. Map Background Color
Cartographica can draw a background color behind all visible features in order to make the features stand
out. Although this may be desirable for maps that are vector-based and have no styles, it can be distracting
for choropleth maps.

You can change the background color for an individual map and also change it for all new maps going
forward.

Procedure 6.18. Changing the background color of a map

1. Choose Edit > Show Colors to bring up the Color Picker

2. Select or create a color of your choosing

3. Drag the color sample from the Color Picker to the Map View

4. Close the Color Picker

Procedure 6.19. Changing the default background color for new maps

1. Choose Cartographica > Preferences… to bring up the Cartographica Preferences window
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2. Click Default Map Background Color color well

The Color Picker will open

3. Select the color for the background

4. Close the Color Picker
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Chapter 7. Map Operations
7.1. Displaying the Scale

You can display the scale for the Map currently showing in the Map Window. To show the Scale box,
Map > Show scale. A small Scale box appears in the lower right-hand corner of the Map window. Notice
this Scale box gives the current scale, and changes as you zoom in and out of the map.

7.2.Trimming Maps
Trimming maps allows you to take a map that contains more information than is necessary for your task
and make it smaller. You can trim a full map to a selection window that you make, or trim a map based
on the smallest map possible containing all of the feature on a given map.

Procedure 7.1. Trimming a Map to a layer's extent

1. Select the layer in the Layer Stack

2. Choose Map > Trim Map to Extent of Selected Layer

Cartographica will remove all data outside of the extent of the selected layer from the map on all
layers

Procedure 7.2. Trimming a Map to a feature's extent

1. Select the layer in the Layer Stack

2. Select one or more features to trim the map to

3. Choose Map > Trim Map to Extent of Selected Features

Cartographica will remove all data outside of the extent of the selected features from the map on all
layers

Procedure 7.3. Trimming a Map to a feature's area

1. Select the layer in the Layer Stack

2. Select one or more features to trim the map to

3. Choose Map > Trim Map to Area of Selected Features

Cartographica will remove all data not included within the area of the selected features

7.3. Changing the Projection of a Map
You can change the projection in the map window. This doesn't change the underlying data in any layer,
it just coerces the data into that projection for display and output purposes. Any change you make here
affects all of the Layers in the map and will persist until the change is made again using the same method.
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The projection of a map is a way of representing map data on a plane (a "flat" map) either on screen or on
paper. All map projections distort the surface in some way. Depending on the purpose of the map, some
distortions are acceptable and others are not; therefore different map projections exist in order to preserve
some properties of the original shape in the flat map representation. You can choose from different projec-
tions to see which more accurately represent your data and which compromises are most acceptable to
you. You decide what the projection will be. Some representations of projections include the United
Kingdom using the British Grid or Equal Area Projections giving maps of the United States that "curved"
look or even using different map projections to give a 3D look to a map like you might see on a GPS display.

To change the target projection of a map:

1. Map > Project map.

The Project Map dialog appears.

Figure 7.1. Project Map Window

2. From the left side of the dialog, choose the map projection that best suits your needs.

The Description box on the right will change depending which projection is selected. You can also
click the Specifications tab to see additional details about the selected projection.

Below this informational area there is a small preview are that gives a general orientation for the features
of your map once the selected projection has been confirmed.

You can use the search/filter box to find a particular projection (or group of projections) and narrow
down your choices. As you type in the search box, the projections that do not match the search criteria
are automatically removed, creating a smaller list from which to choose.
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3. Once you have the selected the projection that best suits your needs and most accurately represents the
data you are attempting to display, click Set.

7.4. Showing Information About the Map
To show information about the map layers Map > Map Info.

The Map Info Window appears.

Figure 7.2. Map Info Window

This window shows the data about each layer in the map and also general data about the entire map such
as number of points and what the geometry types of each of the points. When you click on the Layer in
the left-side window, the data in the right-side window changes to show the information for the selected
layer.

76

Map Operations



Chapter 8. Analyzing Data In
Cartographica
8.1. Introduction to Cartographica Analysis

Cartographica's second calling, behind importing and displaying data, is analysis of that data. There are
many options in the Tools menu for performing analysis and we will be adding more as time goes on.

There are two basic kinds of analysis functions, grouped by the type of resulting data. Analyses that result
in a raster layer provide smooth visual outputs and selectable color maps, etc. Analyses that result in either
new vector layers or modifications to existing vector layers provide high levels of scalability and are often
more useful for further analysis. Some functions may be able to output either vector or raster data.

8.2. Making a Kernel Density Map (Raster)
Kernel Density Maps are a way to look at the relative density of point data as spread over an area. The
Cartographica Kernel Density Map option uses a highly-accurate Kernel for its analysis. By default, the
kernel density analysis uses a set of "reasonable" parameters, however an advanced version of the feature
is available by holding down the Option key on your keyboard while selecting the menu item that allows
you to change those defaults.

You can make a Kernel Density map on any point layer. This creates an analysis layer (basically a bitmap,
at least visually, but it's actually a "cell" system where each "cell" contains the value for the area bounded
by the rectangle the cell contains).

Depending on your particular data, you may find it helpful to either move this layer to the bottom of your
layer stack, or use the Styles item to change the layer opacity to be more transparent.

To create a Kernel Density Map using the default parameters:

1. From the layer stack, select a single point layer in your mapset for which to analyze the density.

2. Select the Zoom level for the Kernel Density Map in the Map window by zooming in to the view you
want. The default Kernel Density analysis is performed on the area in the Map View at time that you
select the command.

3. Choose Tools > Make Kernel Density Map

After the analysis is complete, the graphical map will be added as a layer to the mapset.

Figure 8.1. Example Kernel Density Map
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To create a Kernel Density Map specifying the precise parameters:

1. From the layer stack, select a single point layer in your mapset from which to analyze the density.

2. Select the Zoom level for the Kernel Density Map in the Map window by zooming in to the view you
want.

3. Hold the Option key and choose Tools > Make Kernel Density Map…

The Kernel Density Map Options window appears.

Figure 8.2. Kernel Density Map Options

Select the options for this analysis:

• Target Layer is the point layer to be analyzed.

• X Cell Count,Y Cell Count,Width, and Height provide a way to change the number (and thus
size, or vice versa) of the cells used in the calculation. The width and height parameters conform
to whatever the target layer's projection is, so if the projection is in State Plane (feet), feet will be
the size. Cartographica analyzes the field using a grid of cells spread evenly across the field. By
setting the count of the grid cells, you can determine the coarseness of the grid that is used.

To change this, either choose the width and height in number of cells, or in map units (here in the
example, it's in degrees, but if your map layer's CRS is set to feet or meters, the parameter will be
in those units).

If the Keep Proportionate check box is checked, Cartographica will adjust the width to match the
height you enter, and vice-versa. For a disproportionate grid, then uncheck the box.

• Fit grid to allows for adjustment of the coverage area of the grid to one of the following:

Layer Bounds constrains to the data in the layer.

Map Bounds constrains to the entire map.
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Visible Map Area constrains to the area currently shown on the map view (where this is useful if
you want the KDM to go beyond the boundary of the current map to provide some context by means
of a smooth drop-off.

• Kernel allows for the specification of the kernel used for the analysis

Table 8.1. Available Kernels

Unbounded. Each data point contributes some-
thing to every cell

Normal (Gaussian)

Bounded. Approximates the normal with a con-
stant k.

Quartic (or Spherical)

Much more weight is given to the center pointsExponential (Negative)

Linear decay with distanceTriangular (Conic)

Bounded. Value is k or 0Uniform (Flat)

Bounded, more spread out than Quartic (or
Spherical) and used in ArcGIS

Paraboloid/quadratic (Epanechnikov)

• Intensity and Weight allow you to assign columns in the layer from which these values are retrieved.
Without changing these parameters, the defaults are to use an intensity and weight of 1.0, which
gives each point equal weight. These two values are multiplied and then added into the cell for the
map. Thus, a cell that contains a single point with a weight of 2 and an intensity of .5 has a value
of 1.

For example, if you have data that is a list of duck-blind positions with the number of ducks seen
in a one hour period, you would set the intensity to the count and that would give you an idea where
the ducks are concentrated.

• Bandwidth is the radius of the band that the point affects in cells and determines the decay of the
value from the central point. If the bandwidth is set to 8, then little or no effect will be generated
by the 8th cell from the point. If you set this number larger, the effect will spread out to a wider
radius.

• k is a parameter specific to a particular kernel function. See Table 8.1, “Available Kernels” for
details.

4. Once you have made your selections click Analyze and the Kernel Density Map is created and added
to the map as a new analysis layer.

8.3. Making a Convex Hull
Convex Hulls are geometric shapes that represent a completely convex "hull" or wrap around a set of data.
They are created using vector polygon layers. If you select multiple features, Cartographica will generate
the Convex Hull around all of the features as a set. If you instead select a layer with no selected items, the
entirety of the occupied layer will be used as points to create the hull.

This works with all geometries, except a single point selection.
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Procedure 8.1. Creating a convex hull

1. Select the Layer that contains the points to add to the Convex Hull.

2. Choose Tools > Make Convex Hull for Selection. Default parameters are used to create the graphic.

The Convex Hull appears on the Map encompassing all of the points you selected in the Data View,
or the entire layer if you have not chosen any more specific points.

A sample Convex Hull looks like this:

Figure 8.3. Sample Convex Hull

8.4. Creating Buffers around Map Features (Vec-
tor)

Buffers are a very common and useful tool employed for data analysis. In it's simplist form, a buffer is an
area created around a feature (point, line or polygon) which keeps the basic shape of the original feature,
but expands the size of the feature by some amount.

Buffers are often used around points to create a survey area. For example, you might create a buffer of 500
ft radius around a set of points representing schools in order to analyze the number of banks within 500 ft
of schools.

Under some circumstances, negative buffers (buffers which are inset from the border of a polygon) are
used to determine internal information about a set of polygonal features. Negative buffers may not be used
with points or lines.

VISUAL EXAMPLE

Procedure 8.2. Create Buffers

1. Select the features you want to create the buffer around

2. Choose Tools > Create Buffers

The Create Buffers sheet appears.
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Figure 8.4. Create Buffers sheet

3. If you want to create buffers in the coordinate system of the original features instead of the map, check
the box next to Create buffers in original features' projections. This is not a common operation,
as it can cause the buffers to appear irregularly shaped.

4. Choose your buffer distance:

• Select the distance that the buffer is created around the features as a number (using the Uniform
Width field. Units will be displayed to the right of the box and if the units are linear, it is possible
to set the units using the pop-up menu next to the box.

• Select the distance that the buffer is created around the features as a Width by Column to have
the current value the specified column determine the radius.

Cartographica currently expects this column size to be scaled to the units of the layer. In the
case of latitude and longitude, that's degrees, in other cases commonly feet or meters. The
units will be displayed, and if the units are linear, it will be possible to change them using
the pop-up menu next to the Uniform Width box.

5. Check Copy Feature Data to Buffer if you want each attribute of the feature being buffered to be
copied to the resultant buffer.

6. Click Buffer….

Cartographica creates a buffer area around the points, lines, or polygons that are in the selection or
selected layer and saves them into a new layer.

Very large and complex geometries with small buffer sizes can take a long time to resolve.

8.5. Counting Points in Polygons
You can also use Cartographica to count the number of points from the target layer that are entirely enclosed
within each polygon in the base layer. In particular, this includes the ability to find out how many points
are contained in a particular area.

Procedure 8.3. Count points in polygons

1. Choose Tools > Count Points in Polygons.
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The Count Points in Polygons Options dialog appears.

Figure 8.5. Count Points in Polygons Options dialog

2. Select the layer containing the data you want counted from the Count Points From drop down menu.

Only point layers will be available

3. Enter a name for the new column in the New Column Name field.

4. Click Count.

The selected points are counted and appear in the data window in a column named as you specified.

8.6. Adding Data Columns
Cartographica contains a number of features to quickly analyze and add columns containing information
about your geospatial data. We'll briefly touch on each mechanism and procedure to do these

Procedure 8.4. Adding Coordinates Columns for Points to the layer

This function adds coordinate columns (X, Y, and optionally Z and M) from the selected point layer. These
data are added to your data table. To add coordinates columns,

1. Select the target layer in the layer stack

2. Tools > Add Coordinates Columns.

Procedure 8.5. Adding an Area Column to the layer

1. Select the target layer in the layer stack

2. To add an Area column, Tools > Add Area Column.

Procedure 8.6. Adding a Length Column to the Layer

1. Select the target layer in the layer stack

2. To add an Area length column, Tools > Add Length Column and the column is added to the layer.

You are adding a length column that displays the length (in layer units) of the lines in the line or
polygon. It is important to note that complex features (polygon layers) have all of their lines summed
total length of all line segments in the polygons, but are measured as their actual length, not as a string
of points.
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For example if you have a complex line which contains a line from San Francisco to Salt Lake and a
line from St. Louis to Washington, DC, the length of that line is the sum of the two lines, not the total
distance from San Francisco to DC stopping in Salt Lake and St. Louis.

For polygons, the data is the length of all line segments in each line. So a polygon with a hole (donut)
will have a length equal to the length of the exterior border of the donut plus the length of the interior
border of the donut.

Procedure 8.7. Adding a Midpoint Coordinates Column to the Layer

1. Select the target layer in the layer stack

2. You can add the coordinates of the midpoints of selected line (only) layers. You are essentially adding
a midX and midY column showing the midpoint of the lines contained in each feature.

To add a midpoint coordinates column, Tools > Add Midpoint Coordinates Column.

If used with complex lines (such as lines with a gap), the midpoint shown will be half-way along the
total distance of the line. In the example used in Adding a Length Column, the "midpoint" will actually
appears as east of St. Louis, since the line from San Francisco to Salt Lake City is shorter than the
line from St. Louis to Washington, DC.

Procedure 8.8. Adding a Centroid Coordinates Column to the layer

1. Select the target layer in the layer stack

2. You can add columns for the coordinates of the centroids of the selected polygon layers. Adding
Centroid columns works only with Polygons.

The centroid is the center of gravity of the polygon. If you have a unit square, the centroid will be at
.5,.5. If that unit square has a hole that is off center, then it won't be. Note also that in the case of
complex polygons or polygons with concavities, the centroid may be outside of the polygon. However,
it is always within the extent of the complex polygon. This adds cenX and cenY columns to the selected
layer.

To add Centroid Coordinates Column, Tools > Add Centroid Coordinates Columns.

Procedure 8.9. Adding a Column showing the Distance to Nearest Feature

You can calculate the nearest distance between the points in a point layer and the features in another layer.
This can be used to calculate nearest neighbor to objects in the same layer or nearest distance to points,
lines, or edges of polygons.

It is not only possible, but often desirable to add distance to the nearest points in the same layer.
In this case, you must be careful to change column names if you want to add any data columns
from the source. Otherwise, you may overwrite the original data with the data from the nearest
feature.

Distance to polygons is the distance to the nearest edge and does not treat specially the case of
being "inside" of a polygon. So, if your point is 5 meters inside of a polygon, the distance will be
5 meters from the polygon, just as it would be if the point were 5 meters outside of the polygon.

1. Select the target layer in the layer stack

2. Choose Tools > Add Distance to Nearest Feature.

83

Analyzing Data In Cartographica



The Distance to Nearest Feature sheet appears, showing the Target Layer into which the distance is
to be added.

Figure 8.6. Distance to Nearest Feature sheet

3. Choose the layer whose features you would like to measure to with the Calculate Distance to pop-
up menu.

4. Enter a name for the new column in the Distance Column box.

5. Optionally, select columns to copy from the Calculate distance to layer to the Target Layer by
checking the Copy box next to the column name and changing the resultant column name (if desired)
by putting a new value in the Copy Name column.

Columns that exist in the Target Layer are used when copying data, so be careful to change
the column name if you don't want to overwrite data in the existing layer.

6. Click Add… to create the column and perform the calculation.

8.7. Geocoding Addresses
Another form of analysis that Cartographica performs is Geocoding, or GEOgraphic enCODING of data
that is not native GIS data. Although similar in some ways to the process of importing other data, there
are two special kinds of data we will treat separately: addresses and photos.

Cartographica has two distinct, and powerful, address geocoding capabilities. Prior to version 1.2, Carto-
graphica provided geocoding based on address information that was already in the map. This was usually
street information received from a government agency or a data provider. More recent versions of Carto-
graphica have also added the ability to geocode using third-party geocoding services. These services provide
high-quality, constantly-updated geocoding capabilities for addresses in a large area of the world. Although
it is easier to set up, there are reasons why you might not want to use it for geocoding. Some of these
reasons include: historical geocoding, where the data that you are geocoding uses streets that no longer
exist or have been realigned since the

The MapBox Geocoder is available to users who have active have active maintenance or active
subscription products. If your Cartographica license is a perpetual license and you need access to
the MapBox Geocoder, you will need to have an active maintenance plan. Included geocoding
services have limits on the number of addresses that can be geocoded without charge.
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The Bing Geocoder requires a Bing Maps access code. Cartographica no longer includes Bing
Geocoding access as part of the subscription or maintenance.

8.7.1. MapBox Geocoding
Using the MapBox geocoder removes most of the configuration headache from the process of geocoding.
In many cases, it is more up-to-date than files that you can obtain about the area that you are geocoding
and it is certainly easier to configure.

Procedure 8.10. Configuring the MapBox Geocoder

1. Choose Tools > Geocoder Options…

2. Select MapBox Geocoder tab and click OK.

You are now ready to geocoder in this map.

8.7.2. Bing Geocoding
Using the Bing geocoder removes most of the configuration headache from the process of geocoding. In
many cases, it is more up-to-date than files that you can obtain about the area that you are geocoding and
it is certainly easier to configure.

If you are using the Bing geocoder, you need to have a valid Bing Maps key, which should be
pasted into the Bing Maps Key (Optional) field in the Cartographica Preferences window.

Procedure 8.11. Configuring Bing Geocoder

1. Choose Tools > Geocoder Options…

2. Select Bing Geocoder tab and click OK.

You are now ready to geocoder in this map.

8.7.3. Internal Geocoding
Geocoding is a complex function and requires all the right data be in place to do it well. Cartographica has
a powerful Geocoding capability, but to use it, you must gather data first. Most data is accurate to the last
census update and may be more recent, based on the government's move to modernize and increase accuracy
in the data or your commercial source. Keep in mind that if you are trying to geocode an old address, your
accuracy may suffer if the data is too new, since some street realignments, renaming, renumbering, and
removals may have changed the landscape since the address data was taken.

In comparison to the geocoding services, the Internal geocoding is much more strict in terms of how it in-
terprets data. So, you should expect to use highly regularized data to match the TIGER/Line files; for ex-
ample, "100 A St SE" in DC will not match "100 A St" using Tiger/Line data.

First, you need to figure out the area of your search. Generally speaking, you want to limit geocoding to
a limited number of counties, to reduce the amount of work necessary on your computer. However, if you
must do a large area, or if your area is undefined, there are geocoding services that can do bulk geocoding
for a small fee.
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Procedure 8.12. Preparing to geocode with TIGER data

1. Locate the TIGER files on the Census Bureau web site. First, go to the TIGER/Line Shapefiles
[https://www.census.gov/geographies/mapping-files/time-series/geo/tiger-line-file.html] page, then
select the particular year you're interested in. To use these files, you will need at least the Edges
layer for the area that you're working with.

2. Locate the appropriate files on the server and download the state, county or counties that you are in-
terested in using for geocoding. After unzipping the files, choose File > ImportVector Data and then
select the edges.shp file for import. This will import the edge data for this area.

3. If you need to geocode more than one census area, you may either merge the two layers into a single
layer and use the new layer as the geocoding layer, or to run the geocoder twice, once with each layer
selected.

4. The next step is to configure the geocoder. Tools > Geocoder Options. If you are using standard
TIGER/Line shape files, Cartographica should set up the geocoder automatically. In most cases, not
only is the layer determined, but the field names are chosen as well. If you are using a file from a
different source, or of a different vintage, you may need to set up the individual field names. At a
minimum, Cartographica requires: Numbers From and Numbers To (for either side of the street or
both), the Street Name, and Street Type (Rd, Ave, etc.). Each of the other entries (prefix and suffix,
zip codes, state, and city) are optional but will increase the accuracy. In the case of City or State, you
may type in value to match the City or State section of the address.

However, it is not a requirement to use TIGER files for geocoding. The need is to have a minimum set of
parameterized lines. Any line layer can be selected as the Geocoding layer.

Procedure 8.13. Configuring Internal Geocoding

1. Choose Tools > Geocoder Options.

The Geocoder Options window appears.
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Figure 8.7. Geocoder Options

2. From the Geocode using layer menu, select the layer that has the attributed lines in it.

3. Each of the geocoding fields in this dialog provides a more specific way to find the data.

For each field in the geocoding layer that you want to match to addresses, select an appropriate Geo-
coding Fields entry and choose the corresponding field. Generally, the more fields that you use, the
more precise the geocoding will be. However, there are times when avoiding certain data fields is
appropriate due to inaccurate data or the format of the original addresses.

The most important features are Street Name, Street Type (ave, rd, street, etc.) and Numbers From
and Numbers To on the right and left sides of the street (indicated by the left and right columns). If
you have these at a minimum, your data will probably geocode pretty well.

If you have Zip Codes for the left and right sides, those can help make things noticeably faster when
working with large sets of lines.

4. If you have data for only one state and the data does not contain a state column, type in the state ab-
breviation in the State field to automatically exclude any addresses not in that state.

5. Once you have selected all of the geocoding options, click OK.
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Once you have set up geocoding, you can use it for the Import Tabular Data or Acquire Database Data
features. Each of these have options to read the data as addresses and then geocode them.

8.7.4. Geocoding vCards
As an easy demonstration of Cartographica's geocoding abilities, you can geocode vCards (or addresses
dragged from the Address Book).

Procedure 8.14. Geocoding your address book

1. Set up the Geocoder options properly.

2. Drag any vCard onto a Map window

A new layer named Geocoded will be created with the address(es) from the vCard(s) you have copied.

8.8. Geocoding Photos
Geocoding photos is a way to take photos and place them on a map in Cartographica. Once these have
been placed, they can be displayed as the point representation of a feature, or displayed when browsing
the map by clicking on point.

There are two ways to geocode photos:

• import files that have already been coded with geospatial data (usually latitude and longitude and using
the EXIF extensions to the JPEG file format)

• using the time code on digital photos to coordinate with information gathered by GPS devices to determine
location

Cartographica currently supports both the import form and the timecoding form, imported either from files
that you select. Photos originating from some cellular phones, such as the iPhone, and from some recently
released cameras with GPS capabilities are the most likely sources of photos that are coded with location.

8.8.1. Importing encoded photos
This process is simple because the photos already contain all of the necessary information to put them on
the map.

Procedure 8.15. Importing photos coded with geospatial data

1. If you are bringing in photos from photo files, choose Tools > Plot GPS Encoded Photos… and select
the picture files in the file window.

2. Choose Tools > Plot GPS Encoded Files

3. Select one or more files to import and plot into the existing map and click Import

Once Cartographica has loaded and coded the files, they will appear in a new layer on the map, with
the location of each photo represented by a point feature.
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8.8.2.Timecoding Photos
The process of importing photos using this method is a bit more involved due to the need to synchronize
the clock information between the camera and the GPS device. If you expect to do this regularly, we suggest
setting the camera's clock to the same time as the GPS whenever you turn on the camera, or at least once
per day. You may also find it useful to set the time on the camera to GMT, as that is the native time of
GPS and therefore requires the least amount of conversion.

Procedure 8.16. Importing photos by matching photo times and GPS tracks

Because the process is dependent upon the coordination between the camera and the GPS device, we describe
the steps here from the beginning of the photo safari to the placement of the photos on the map.

1. Make sure you have valid time synchronization between your camera and GPS

• Sync the time on your camera to the time on your GPS device.

• Alternatively, record the difference between the times. This is easy if you can use your digital
camera to take a picture of the time on your GPS when you start taking photos. However, if your
GPS has no screen, then you should sync to GMT, which is the native time format for GPS data.

2. Take pictures.

3. Download the tracks from the GPS:

• Choose File > Acquire GPS Data to import in directly from your GPS

• Choose File > Import Vector Data to import an existing GPX or other exported data file (such
as those made by ClueTrust's LoadMyTracks [http://www.loadmytracks.com]).

If you are bringing in more than one track file (this might happen on multi-day trips, for example),
you can merge the tracks together by selecting the tracks as a group in the Layer Stack and choose
Layer > Merge Selected Layers.

4. If you are bringing in photos from photo files, choose Tools > Timecode Photos… and select the
picture files in the file window.

5. Click Import and watch Cartographica plot your photos onto the map.

The result is a new point layer containing references to each of the photos placed on the map based on
matching the time and the location.

Unlike geotagging software that writes information back to the file, Cartographica makes no modifications
to the original photo files themselves, guaranteeing the safety and integrity of your image files.

When selecting a point in a layer with photos, you can see a full sized version of the photo by bringing up
the Image Viewer by choosing Window > Show Image Viewer

8.9. Cluster Analysis
Cartographica can perform basic and advanced cluster analysis based on a number of parameters. The
overall algorithm used is DBSCAN, which is a progressive algorithm that is efficient and can find cluster
patterns that elude other algorithms with a minimal amount of pre-configuration. This makes the algorithm
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particularly good for experimental or preliminary analysis, while still remaining effective for detailed
analysis.

Cluster Analysis is for dealing with Point features, and cannot be used with other geometry types.

Procedure 8.17. Performing a Cluster Analysis

1. Select the Layer that contains the points you want to cluster

2. Tools > Find Clusters…

The Find Clusters sheet will appear

Figure 8.8. Find Clusters sheet

Shortly after the sheet comes up, the Average Distance (average nearest distance for points in this
layer) and NNI (the Nearest Neighbor Index–a value describing how likely it is that the data forms
clusters; if the value is <1 it is likely clustered).

3. Adjust the Minimum Count to be the minimum number of points in a cluster

4. There are 3 distance functions that can be used in determining whether a point can be clustered with
other points, of which you must choose one:

• Fixed distance will be in the coordinate system of the Map (which is consistent with Cartographica
analysis tools)

• Average Nearest Neighbor Distance is based on the average nearest neighbor distance, and the
value with the stepper indicates the number of standard deviations to include

• Expected Mean Distance is based on a confidence interval based on the expected density of the
area

The techniques, and especially the Expected Mean Distance confidence intervals are modeled
on those used by CrimeStat [https://www.icpsr.umich.edu/CrimeStat/].

5. Finally, when you are satisfied with the parameters, click Find
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The result layer will be added to your map as a new Polygon layer with a name based on the name of
the layer to be analyzed

8.10. Spatial Join
Cartographica has a number of powerful facilities to provide for geospatial analysis and feature attribute
propagation, among these is the powerful Spatial Join operation. 

Spatial Joins are used to combine the data attributes of two or more layers. The Spatial Join operation
creates a new layer that is a combination of attributes from Join and Target layers. The Spatial Join functions
are akin to the Overlay functions except that the Spatial Join procedure does not change the geometry of
the layers. Spatial Joins can be used for many different purposes and there are many options for determining
how the join will be processed.

A Spatial Join can be performed on point, line, or polygon layers. The resulting vector layer will match
the Selected layer's data format (i.e. point, line, or polygon). For example, if you select a polygon layer
and then perform a Spatial Join (using an Intersect function) with a point layer as the Join layer, the output
would be a polygon layer with attribute data joined from the point layer. In this case one attribute added
to the polygon layer would be a count of the number of points that intersected with each polygon in the
Selected layer. 

The default Spatial Join option is the Intersection function, which will join two layers that overlap in space.
In addition to the Intersection function there are 15 additional methods for performing Spatial Joins that
can be used to fit various situations.

Table 8.2. Spatial Join Operations

Suitable GeometryDescriptionSpatial Join Operation

Any and AnySelected layer feature intersects
join layer feature at any point

Intersecting

Any and AnySelected layer feature intersects
join layer featureat any point (3D)

Intersecting (3D)

Any and AnySelected layer feature is within
distance of join layer feature at any
point

Within Distance

Any and AnySelected layer feature is within
distance of join layer feature at any
point (3D)

Within Distance (3D)

Polygons may contain AnySelected layer feature contains any
portion of the join layer feature

Contains

Lines may contain lines or points(differs from intersection in that

Points may not be the selected
layer.

touching only at boundaries is ex-
cluded)

Polygons may contain AnySelected layer feature contains all
 the join layer feature 

Completely Contains

Lines may contain lines or points

Points may not be the selected
layer.
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Suitable GeometryDescriptionSpatial Join Operation

Polygons may be within PolygonsSelected layer feature is within if
contained within the join layer
feature.

Within

Lines may be within Lines

Points may be within Lines or
Polygons

Effectively Contains, but with the
opposite result layer

Polygons may be within PolygonsSelected layer feature is within if
completely contained within the
join layer feature.

Completely Within

Lines may be within Lines

Points may be within Lines or
Polygons

Effectively Completely Contains,
but with the opposite result layer

Polygons may contain AnySelected layer feature contains all
of the join layer feature, but the

Within (Clementini)

Lines may contain Lines or Pointsjoin layer must be at least partially

Points may not be the selected
layer.

within the body of the selected
layer feature (i.e. cannot only be
coincident with the edge).

Any may be identical to the sameSelected layer feature is identical
to the join layer feature

Identical To

Any and AnySelected layer feature touches the
join layer feature (but does not
cross).

Touches Boundary

Polygon or Line and Polygon or
Line

Selected layer feature shares a line
segment with the join layer feature.

Shares a line segment

Polygon or Line and Polygon or
Line

Selected layer feature is crossed
by the outline of the join layer
feature.

Crossed by the Outline

Any and AnySelected layer feature's center falls
within the join layer feature. (Cen-

Have Center Within

ter for point is the point; for line is
the midpoint; for multipoint or
polygon is the centroid)

Any and AnyThe join layer feature closest to the
selected layer feature.

Closest

Join Parameters

In addition to the Spatial Join Operation, there are a few parameters that modify the behavior of the oper-
ations:

• Maximum Distance defines the maximum distance for the distance operations (Within Distance,
Within Distance (3D) and Closest).

• Distance Column Name defines the column name of a column to contain the distance when used with
any of the distance operations (if left blank, no distance will be stored).

• One Feature per Match, if checked, generates a new copy of the Selected layerfeature for each match
with a Join Layer feature.
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• Discard Unmatched Features, if checked, will not generate a Selected Layer feature in the event that
there is no match with the Join Layer feature.

Field Mapping

The Field Mapping box determines the mapping between the incoming fields (from both the Selected
layer and the Join layer) as well as a few special calculated columns. The table shows the following
columns, in order:

• Operation The operation to perform and store in this output column

Table 8.3. Field Mapping Operation

ResultOperation

Matching feature's data will be copiedCopy

No column will be createdIgnore

Minimum value of matching features' dataMin

Maximum value of matching features' dataMax

Value of first matching feature's dataFirst

Value of last matching feature's dataLast

Sum of matching features' dataSum

Average of matching features' dataAverage

Count of matching features with dataCount

Sigma calculation of matching features' dataSigma

• Layer The original layer that the data comes from.

• Original Name The name of the original column that the data comes from

• Output Name The name of the output column

• Ratio When checked, this indicates to calculate any value based on the ratio of the combined feature
(only valid for the numeric operations). In particular, this checkbox will multiply the column value times
the area (in case of the polygon) or length (in case of a line) in the join feature relative to the join features
entire area or line. This is only relevant to the Intersection, Contains, Within operations for polygons
and some boundary operations with lines.

It is possible to create additional output columns for the same original field. To do this, select the
desired field and choose Duplicate This Mapping from the pop-up menu by using ctrl-click. This
can be handy when you need multiple numeric calculations on the same original column.

In addition to the fields from the Selected and Join layers, there are 3 specialized columns that are automat-
ically created:

• JOIN_FID The feature ID of the join layer feature

• TARGET_FID The feature ID of the selected layer feature

• Join_Count The number of join features that matched this selected layer feature. If One Feature per
Match is checked, then this should never be more than 1.
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Procedure 8.18. Using Spatial Join

1. Select the layer you want to use as the primary layer. This is the one from which features will be
copied to the result layer.

2. Choose Tools > Spatial Join….

The Spatial Join sheet appears

Figure 8.9. Spatial Join sheet

3. Choose from one of the Spatial Join operations (discussed previously in Table 8.2, “Spatial Join Op-
erations”)

4. Select the join layer in Select Join Layer box.

5. Make desired changes to the output fields in the Field Mapping box

6. Click Join

8.11. Overlay Operations Tool
Another tool in Cartographica for promulgating attributes between layers is the Overlay Operations tool.
This tool, and its associated operations, provide a way to manipulate both the attributes and the geometry
of layers. Each overlay operation has a different geometric effect, and can also contribute attributes to the
target layer(s).
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Spatial Joins are used to combine the data attributes of two or more layers. The Spatial Join operation
creates a new layer that is a combination of attributes from Join and Target layers. The Spatial Join functions
are akin to the Overlay functions except that the Spatial Join procedure does not change the geometry of
the layers. Spatial Joins can be used for many different purposes and there are many options for determining
how the join will be processed.

A Spatial Join can be performed on point, line, or polygon layers. The resulting vector layer will match
the Selected layer's data format (i.e. point, line, or polygon). For example, if you select a polygon layer
and then perform a Spatial Join (using an Intersect function) with a point layer as the Join layer, the output
would be a polygon layer with attribute data joined from the point layer. In this case one attribute added
to the polygon layer would be a count of the number of points that intersected with each polygon in the
Selected layer. 

The default Spatial Join option is the Intersection function, which will join two layers that overlap in space.
In addition to the Intersection function there are 15 additional methods for performing Spatial Joins that
can be used to fit various situations.

Table 8.4. Overlay Operations

DescriptionOperation

Target layer features are clipped to the features in
the clipping layer.

Clip

Erase the target layer(s) with the erase layer. Portions
in the target layers that match the erase layer are re-
moved.

Erase

Features that overlap with all target layers are main-
tained. Note that this differs from clipping in that

Intersect

features are removed if they aren't present in all lay-
ers.

Features in all Target Layers are kept. Overlapping
features are combined.

Union

Features present in more than one layer are removed
(possibly partially) to result in a layer that contains

Difference

only the pieces of features that are only present in a
single layer.

Target layers are updated with geometry in the Up-
date layer. Overlapping geometries will be replaced,

Update

and non-overlapping geometries (or parts thereof)
will be retained.

Target layers are identified with the geometry in the
Identify layer. Overlapping geometries will be up-

Identify

dated to contain information from the Identify layer.
Partially-overlapping geometries will be split into
overlapping and non-overlapping parts.

Procedure 8.19. Performing Overlay Operations

1. Choose Tools > Overlay Operations….

The Overlay Operation sheet appears
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Figure 8.10. Overlay Operation sheet

2. Choose from one of the Overlay operations (discussed previously in Table 8.4, “Overlay Operations”)

3. Select your target layer(s) in Target Layers

4. If appropriate, drag an operation layer from the Target Layers box to the operation box (which will
be labeled according to the operation)

5. Adjust your Field Mappings as appropriate. Operation is identical to the Field Mapping section.

6. Click Perform

Once the operation is complete, new layers corresponding to the Target Layers should appear in the
Layer Stack.

8.12. Raster Interpolation
Cartographica contains a powerful analysis tool for generating Raster layers from vector point data. This
tool can interpolate using a number of mechanisms in order to "fill in the gaps" of data based on a selection
of algorithms. It should be noted that all of these algorithms are interpolations and you should consider
the raster data to be a type of approximation, as opposed to accurate information. However, this tool can
be useful for visualizing sparse data sets or data sets whose density varies.

The interpolation system uses the underlying GDAL grid system for its implementation.
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For algorithms that use search ellipses, the angle of the ellipse rotation (counter clockwise, zero along the
axis) is Angle and the radii of the ellipse are Radius1 (along the X axis at Angle 0), and Radius2 (along
the Y axis at Angle 0).

Table 8.5. Interpolate Point Data Algorithms

ParametersOverviewInterpolation Algorithm

The inverse distance to
a power method uses the weight

Inverse distance to a power • Power

• Smoothingand smoothing to calculate the
grid value. If the ellipse radii (radi-

• Radius1us1 and radius2) are not set, then
every point contributes to the

• Radius2
value, based on the inverse of its
distance to the grid node. • Angle

If the ellipse radii are set and Max
Points is set, at most that many of

• Max Points

the nearest points within the radius
are used.

• Min Points

If the ellipse radii are set and Min
Points is set, the grid node is con-
sidered empty if fewer than that
many points are found.

The inverse distance to
a power method uses the weight

Inverse distance to a power with
nearest neighbor searching

• Power

• Smoothingand smoothing to calculate the
grid value.

• Radius

The circle radius (radius) should
be set to a non-zero radius. • Max Points

If Max Points is set, at most that
many of the nearest points within
the radius are used.

• Min Points

If Min Points is set, the grid node
is considered empty if fewer than
that many points are found.

The moving average uses a moving
search ellipse in which all points

Moving average • Radius1

• Radius2are averaged when computing grid
node values. Note, that it is essen-

• Angletial to set search ellipse for moving
average method.

• Min Points

If Min Points is set, the grid node
is considered empty if fewer than
that many points are found.

The Nearest Neighbor method
takes on the value of the nearest

Nearest neighbor • Radius1

• Radius2neighbor within the ellipse defined
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ParametersOverviewInterpolation Algorithm

by the Angle, Radius 1 (X axis at
angle 0), and Radius 2 (Y axis at

• Angle

angle 0). If the Radius values are
both 0, the entire point array is
used.

If no points are found within the
ellipse, the grid node is considered
empty.

The Linear method performs linear
interpolation by computing a

Linear interpolation • Radius

Delaunay triangulation of the point
cloud, finding in which triangle of
the triangulation the point is, and
by doing linear interpolation from
its barycentric coordinates within
the triangle. If the point is not in
any triangle, depending on the radi-
us, the algorithm will use the value
of the nearest point or the nodata
value.

If Radius is set to -1, the search
distance is infinite.

Procedure 8.20. Interpolating Point Data

1. Select the layer you want to use as point source.

By selecting features within the layer, you can limit the point source to just the selected fea-
tures.

2. Choose Tools > Interpolate Point Data….

The Interpolate Point Data sheet appears
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Figure 8.11. Interpolate Point Data sheet

3. Choose from one of the Algorithms (discussed previously in Table 8.5, “Interpolate Point Data Al-
gorithms”)

4. Make desired changes to the parameters

5. Click Analyze…

When complete, a new layer will be added to your map.
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Chapter 9. Working With Raster Layers
Raster layers contain data a "coverage" of data that is sampled at equal intervals over an area. Often, these
are satellite or orthophoto imagery (in which case, the reflected light from the surfaces is the data that was
sampled), or LIDAR information (in which case it is the laser reflectivity that was sampled). In other cases,
these data sets contain information from other sources, such as regular point samples of chemical concen-
tration or regular samples of the height above a particular known level.

Styling the raster data was already covered in Section 6.2, “Styling Raster Layers”.

Cartographica 1.5 and newer contain raster analysis tools that can be used to transform raster data.

9.1. Merging Raster Layers
You can use Merge Raster Layers when working with raster data (such as satellite imagery from Landsat)
that is split into separate layers for each color component. When using this data to show visible light, the
layers (usually Red, Green, and Blue layers) must be merged into a single layer.

Procedure 9.1. Merging Raster Layers Automatically

1. Select the Raster Layers you want to merge.

2. Choose Tools > Merge Selected Raster Layers.

Cartographica takes the selected layers in the order of the layer stack as Red, Green, Blue, and option-
ally alpha. Alpha is equivalent to transparency/opacity, where the minimum value is completely
transparent, and the maximum value is completely opaque.

When merging layers manually, you have control over which layers to use, which can be helpful in re-ar-
ranging layers or in creating effects by using the same layer in more than one color band.

Procedure 9.2. Merging Raster Layers manually

1. Select the Raster Layers you want to merge.

2. Hold down the Option key and choose Tools > Merge Selected Raster Layers

The Merge Raster layers Options dialog appears.
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Figure 9.1. Merge Raster Layers Options dialog

3. For each layer that you want to use, select a Raster Layer from the pop-up. Each layer may be selected
zero or more times.

4. Check Remove Used Layers to delete the original layers once they have been merged. Leave it un-
checked to leave the layers in place.

The original files on disk are not affected by the merging and will not be removed regardless
of this setting.

5. Click Merge and the layers are merged and the new layer appears in the Layer stack.

9.2. Georeferencing Raster Layers (side-by-side)
This section covers the new side-by-side georeferencing tool, introduced in Cartographica 1.5.

There are times when raster data is delivered without spatial reference information. If you have an ungeor-
eferenced image, you will need to georeference it before it will show up correctly on the Map. In these
cases, Cartographica can be used to adjust the images for their location, a process called Georeferencing.

Georeferencing is often a tedious task, and if there's a possibility that the spatial components exist
for the raster files you are working with, you should seek these out.

Cartographica has the ability to georeference raster data manually through the use of Ground Control Points
or georeference matrices. Georeferencing involves telling Cartographica the location and size of the raster
image relative to some known Coordinate Reference System (CRS), so that it can be displayed correctly
along with other data. In order to appropriately georeference an image, you will need to have some form
of reference layer, such as a vector map of the area or a live map.

In order to adjust georeferencing via a matrix, refer to the Section 9.3, “Georeferencing Raster Layers (in-
place)”. That mechanism is mostly of use when you have knowledge of the exact location of an image as
well as the size of an individual pixel in x and y directions. For most manual georeferencing, you will want
to use this mechanism.
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Procedure 9.3. Georeferencing Raster Layers

With side-by-side Georeferencing, Cartographica displays two separate maps in the same window (see
below). The left side of this window contains the reference map (the Mapset you are currently working
with, initially without the layer being georeferenced), and the right side of the window contains the layer
to be georeferenced.

The general process is to use the standard option-click on one side and then the other to match points. Once
you have at least 4 (although preferably quite a few more, especially if the points are not in a large area),
then the layer can be georeferenced.

Figure 9.2. Georeference Window

1. Begin with a Mapset into which you want to load the Raster imagery. This can be an empty Mapset,
or one containing a multitude of layers. In general, you want to have at least one layer (so that you
can set the Map Projection, which will be used as the projection for the georeference.

2. Choose File > Import Raster Data… to import the desired Raster image into your Mapset. If it is
not already georeferenced don't worry about any changes to the visuals in the Map, as they will only
last until you have georeferenced the image. If it is distracting, or distorting your reference Mapset,
you can uncheck the box next to the layer name to hide the layer.

3. Select the Raster layer to be georeferenced.

4. Choose File > Georeference Image…

The Georeferencing window will appear

5. If the reference material in your map is sufficient for the task, you're good to move on to the next
step. However, if you desire to use a Live Map tile reference, you can use the drop-down menu above
the reference (left) pane, to change from Existing Map to Live Map. By default, the the Live Map
shows the map with roads. You can use the Map Style sub-menu to change between Roads, Aerial
Imagery and Aerial Imagery with Roads.
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6. You can use the tools in the Map menu to toggle between the Zoom, Pan, and Identify modes that
work just like the same modes in a normal Map window.

7. Once you have located a suitable reference point, use the Identify mode ( Map > Identify) and then
control-click once on the left side to mark the reference location, and once on the right side to mark
the image location. Once you've placed the markers on the map, they will be represented by a circle
with a number atop it. The circle will be filled with white when the point pair is selected. Selecting
a point on either side will select the corresponding point on the other side as well, as shown below:

Figure 9.3. Georeferencing with Points Selected

8. If necessary, you can click on an existing point and move it (either by dragging it, or by nudging it
using the arrow keys on the keyboard).

9. Repeat these steps until you have a suitable count (>4) and distribution (representing most of the area)
of reference points.

10. When this is complete, close the Georeference window to save the georeferencing information.

Procedure 9.4. Modifying Existing Georeference

There are times when an existing georeference needs changing. Cartographica treats the georeference
points as data which travels with the Mapset, so you can edit the georeference points in the future if necessary
to adjust precision in certain areas.

1. Select the Raster layer in your Mapset to edit

2. Choose Tools > Georeference Image…

The Georeferencing window will appear.

3. Edit the reference points as described above.

4. When complete, close the Georeferencing window to save the georeference information
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9.2.1. Notes and Tips for Georeferencing
• If your image on the right shows upside down when you first begin, click on the Flip button to flip the

image vertically.

• The Reference map menu on the left pane can be used to change between different reference maps while
you perform the georeferencing. You may want to try flipping between a tiled reference, such as live
maps and your existing Mapset.

• When using your current Mapset as a Reference map, you can also toggle the inclusion of the georeference
layer itself by choosing Show Georeference Layer in the Reference map menu. This provides basically
an in-situ preview.

9.3. Georeferencing Raster Layers (in-place)
This section covers the original Cartographica In-Place georeferencing tool. For most georeferencing needs,
we suggest using the newer Section 9.2, “Georeferencing Raster Layers (side-by-side)” tools, introduced
in version 1.5.

There are times when raster data is delivered without spatial reference information. If you have an ungeor-
eferenced image, you will need to georeference it before it will show up correctly on the Map. In these
cases, Cartographica can be used to adjust the images for their location, a process called Georeferencing.

Georeferencing is always a difficult an tedious task, and if there's a possibility that the spatial
components exist for the raster files you are working with, you should seek these out.

Cartographica has the ability to georeference raster data manually through the use of Ground Control Points
or georeference matrices. Georeferencing involves telling Cartographica the location and size of the raster
image relative to some known Coordinate Reference System (CRS), so that it can be displayed correctly
along with other data. In order to appropriately georeference an image, you will need to have some form
of reference layer, such as a vector map of the area or a live map.

Procedure 9.5. Georeferencing Raster Layers

1. Make sure you have a reference layer loaded, unless you are manually setting the matrix or ground
control points. A vector map of the area or a live map are often good choices for this.

2. Verify that your reference layer is included in the Map Extent. This will be the default for most Vector
and Raster layers, but not for Live Map layers. Select the reference layer in the Layer Stack and the
make sure Layer > Include in Map Extent is checked.

3. Load your Raster layer by using drag-and-drop or File > Import Raster Data...

4. Click on the new Layer in the Layer Stack to select it

5. Choose Layer > Set Layer's Projection to choose the CRS in which the layer will be referenced
(usually the same as the current map or the reference layer).

6. Zoom and pan the reference layer until you can see a location that is basically the same area as the
area of the raster layer. Ignore for the time being the raster layer, since it likely will be very far away
from its actual location to start with.

7. Choose Edit > Georeference Image...  to begin the georeferencing
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8. At this time, the Georeference panel should come up, providing control over the georeference process.
By default, it starts in Ground Control Point mode, which allows you to drag the dots in order to match
points in the reference layer.

9. Click Fit Display

At this time, the Raster image should be visible on the screen (although probably not in exactly the
right place).

10. If your raster layer appears upside down, click Flip Vertical to correct that.

On a machine with a trackpad, you can adjust the image's size and rotation using pinch and
zoom and rotate.

Arrow keys can be used to "nudge" the position of the raster image

11. The mouse can be used to move the existing four corner GCPs so that they align with data in the ref-
erence layer

If you hold the Option (Alt) key down and click, you can create new GCP anywhere within the image.
Option-click on the image to create the reference and drag to the point in the reference layer that
represents that location. With more than 4 locations, a minimum of 7 GCPs is suggested for smooth
representation.

12. When you are done with the georeferencing, choose Edit > Georeference Image... to end the edit

9.4. Processing Height Rasters
When working with Digital Elevation Model (or DEM) data, there is frequently the need to perform some
analysis of the elevation data and how it relates to its surroundings. The Tools > Process Height Raster…
command is intended to provide much of that capability in Cartographica. Based upon the GDAL libraries,
Cartographica can perform a number of processing steps, including:

• Hillshade (shaded relief)

• Slope

• Aspect

• Color Relief

• Terrain Ruggedness Index (TRI)

• Terrain Position Index (TPI)

• Roughness

Cartographica performs these functions based on the selected layer or layers. As such, multiple raster layers
can either be merged together and then analyzed, or they may be analyzed by selecting multiple layers and
then choosing Tools > Process Height Raster….

Procedure 9.6. Processing Height Raster Layers

1. Select the layer or layers to be processed in the Layer Stack
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2. Choose Tools > Process Height Raster…

The Process Height Raster sheet will come up

Figure 9.4. Process Height Raster sheet

3. Choose the type of processing you would like by selecting one of the tabs in the sheet

4. If there are options in the window, you may fill those in and then click Process to perform the pro-
cessing

A new layer will be created in the Layer Stack with the output of the processing

9.4.1. Supported Algorithms
All of the algorithms for these calculations come from recent versions fo the GDAL libraries. Here we
present a summary of the functionality and parameters, based on the documentation.

9.4.1.1. Hillshade

The Hillshade processor creates an 8-bit raster with a shaded relief effect. It is mostly useful for visualizing
terrain. Adjustments can be made to the azimuth and altitude of the light source, and scaling information
can be added to account for differences between the vertical and horizontal units.

Many of these algorithms expect that the X, Y and Z scales are the same in the original data. For
data that is consistently in meters (x and y in a local projected coordinate system in meters, and
the DEM data itself in meters), there's no need to adjust the scaling. However, in the case the the
source layer is in Lat/Long (for example), the scale will need to be set to 111120 if the DEM data
are in meters and 370400 if they are in feet.

Table 9.1. Hillshade Parameters

Vertical exaggeration used to pre-multiply the elev-
ation data. This may be necessary when trying to

Z factor

accentuate the height differences, for example for
areas that are relatively flat.
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Ratio of the vertical units to horizontal. (See note
above)

Scale

Azimuth of the light source, in degrees. 0 is from the
top the raster image, 90 from the right side (East of-

Azimuth(°)

ten). The default value is 315° is commonly used for
shaded maps, and should be considered a standard.

Altitude of the light source, in degrees. 90 if the light
comes directly above the DEM, 0° if it is raking light.

Altitude(°)

The default value of 45° is commonly used for
shaded maps.

Use a combination of oblique and slope shading. If
not checked, it will use just oblique shading.

Combined

Use Multidirectional shading, a combination of hill-
shading illuminated from 225°, 270°, 315° and 360°.

Multidirectional

Applies the formula from Multidirectional, oblique-
weighted, shaded-relief image of the Island of Hawaii
[http://pubs.usgs.gov/of/1992/of92-422/of92-422.pdf]
from the USGS [https://usgs.gov/].

Shading which attempts to minimize effects on other
map features by rendering a "softer" hillshade. Uses

Igor

the techniques covered in Igor's hillshading method
[http://maperitive.net/docs/Commands/GenerateReliefImageIgor.html]
from Maperitive.

9.4.1.2. Slope

Creates a 32-bit float raster with slope values as either percent or degrees. Where appropriate a no-data
value of -9999 is used.

Table 9.2. Slope Parameters

Ratio of the vertical units to horizontal. (See note
above)

Scale

Checked if the output values should be as a percent,
otherwise they are in degrees

Slope as Percent

9.4.1.3. Aspect

Creates a 32-bit float raster with values between 0° and 360° representing the azimuth that slopes are facing.
The definition of the azimuth is such that:

Table 9.3. Aspect Parameters

TrigonometricAzimuthAngle

Facing EastFacing North0°

Facing NorthFacing East90°

Facing WestFacing South180°

Facing SouthFacing West270°
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This presumes that the raster input is North at the top when the data is processed). Where appropriate a
no-data value of -9999 is used.

Table 9.4. Aspect Settings

Provide trigonometric angle instead of azimuth (see
table above)

Trigonometric

Return 0 for areas with a flat slope, instead of -9999Zero for Flat

By checking both of these options (Trigonometric and Zero for Flat), the aspect returned should
be identical to the one from GRASS r.slope.aspect. Otherwise, it is similar to the output
of Matthew Perry's aspect.cpp [https://github.com/perrygeo/archive/tree/master/demtools].

9.4.1.4. Color Relief

This process creates a 3-band (RGB) or 4-band (RGBA) raster with values that are computed from the el-
evation and from the color configuration, which provides a mapping from various elevation values to a
corresponding desired color. Color blending is handled based on the settings in the Color Blending Mode
table, and an optional Alpha channel can be added, which affects both blending and the use of exact color
(in the case of exact color, non-matching colors are transparent).

Table 9.5. Color Blanding Modes

EffectBlending Mode

Only exactly matching colors are set. All other values
result in (0,0,0) or (0,0,0,0) if alpha is enabled

Exact Match

The color in the Height/Color map which is nearest
is used

Nearest Color

A proportionate blend between the nearest 2 colors
is used

Smooth Blend

9.4.1.4.1. Specifying Height/Color Mapping in Color Relief Processing

Height/Color mapping can be provided either by manually entering items into the table or by loading color
mapping files. The color mapping files are simple text files which have a list of heights and their corres-
ponding color values. The values column (leftmost) contains the elevation value, which may be a floating
point value, a percentage value (appended with %), or nv to indicate no data (no value). The color columns
may contain a textual color value (currently supported values are: white, black, red, green, blue, yellow,
magenta, cyan, aqua, grey/gray, orange, brown, purple/violet and indigo), an RGB triple (red, green, blue),
or an RGBA quad (red, green, blue, alpha). In the case of the multi-values, the values range from 0 to 255
and may be separated by spaces, commas, tabs, or colons (:). Finally, the absence of an alpha value denotes
full opacity (255).

3500 white
2500 235:220:175
50%  190 185 135
700  240 250 150
0    50  180  50
nv   0   0    0   0                    
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Procedure 9.7. To specify Height/Color mapping manually

1. Click + to add a new row

2. Click in the Height Level of the new row and put in an elevation or %age

3. Click in the corresponding Color Specifier and put in a color name, or 3 or 4 values from 0-255 (3
for RGB, 4 for RGBA)

4. (Optional) Value sets may be saved to a file by choosing Color Sets > Save… from the drop-down
menu beneath the table

5. (Optional) Value sets may be loaded from a file by choosing Color Sets > Load… from the drop-
down menu beneath the table

9.4.1.5.Terrain Ruggedness Index (TRI)

This process creates a single-band raster with values computed based on the elevation and the mean differ-
ence between a central pixel and its surrounding cells. For details, see Multiscale Terrain Analysis of
Multibeam Bathymetry Data for Habitat Mapping on the Continental Slope
[https://www.researchgate.net/profile/Anthony_Grehan/publication/228670890_Multiscale_Terrain_Analysis_of_Multibeam_Bathymetry_Data_for_Habitat_Mapping_on_the_Continental_Slope/links/09e41509248af0092c000000/Multiscale-Terrain-Analysis-of-Multibeam-Bathymetry-Data-for-Habitat-Mapping-on-the-Continental-Slope.pdf].

9.4.1.6.Topographic Position Index (TPI)

This process creates a single-band raster with values computed based on the elevation and difference
between a central pixel and the mean of its surrounding cells (also from Multiscale Terrain Analysis of
Multibeam Bathymetry Data for Habitat Mapping on the Continental Slope
[https://www.researchgate.net/profile/Anthony_Grehan/publication/228670890_Multiscale_Terrain_Analysis_of_Multibeam_Bathymetry_Data_for_Habitat_Mapping_on_the_Continental_Slope/links/09e41509248af0092c000000/Multiscale-Terrain-Analysis-of-Multibeam-Bathymetry-Data-for-Habitat-Mapping-on-the-Continental-Slope.pdf]).

9.4.1.7. Roughness

This process creates a single-band raster with values computed based on the elevation and the largest inter-
cell difference of a central pixel and its surrounding cells (also from Multiscale Terrain Analysis of Mult-
ibeam Bathymetry Data for Habitat Mapping on the Continental Slope
[https://www.researchgate.net/profile/Anthony_Grehan/publication/228670890_Multiscale_Terrain_Analysis_of_Multibeam_Bathymetry_Data_for_Habitat_Mapping_on_the_Continental_Slope/links/09e41509248af0092c000000/Multiscale-Terrain-Analysis-of-Multibeam-Bathymetry-Data-for-Habitat-Mapping-on-the-Continental-Slope.pdf]).

9.5. Creating Contours
When analyzing digital elevation data, it is frequently useful to be able to take elevation or height data
from a raster source and create a vector representation of that for further analysis. In Cartographica, this
is done using the Create Contours command.

Procedure 9.8. Creating Contours from DEM

1. Select the DEM layer (or layers) from the Layer Stack

2. Choose Tools > Create Contours…

The Create Contours sheet will be displayed, showing the maximum and minimum heights on the
left side, and providing two ways to create the contour levels on the right side.
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Figure 9.5. Create Contours sheet

3. For automatically calculated contours, enter your desired lowest contour in the Base field and the in-
crements at which you want to space the contours in the Increment field. In the example above, the
base of 0 and Increment of 170 will result in 10 contour lines at 0, 170, 340, 510, 680, 850, 1020,
1190, 1460, and 1630. Items above 1630 will be in the 1630 contour (since the range of this data is
158-1651).

4. To manually choose the contour levels, click Manual and then use the + and - buttons to add and re-
move contour levels

5. Click Create to run the contour analysis

A new layer named with the name of the layer and Contours appended will be added to the Layer
Stack
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Chapter 10. Editing Features
10.1. Editing and Adding Features

In some cases, you need to add geospatial data to a layer without exacting precision. Cartographica supports
manual editing (and creation) of features in new and existing layers in order to facilitate this.

Feature editing is done in Edit Mode, where your changes are only temporary until you commit them. In
edit mode, all of the layers (including the one containing the feature you are editing are "ghosted" behind
the editing area so that you can still make out where in the coordinate space you are, but those features
don't interfere with your navigation and editing.

When in edit mode, all navigational and zooming features are still available, so feel free to do things like
Zoom To Feature or pan around in order to make your working canvas as appropriate as possible.

Individual points in features are shown using red dots. When these points are selected, the dots become
hollow (have a white circle inside of them) to mark the selection. New points are inserted next to the cur-
rently selected point by holding down the Option key and clicking your mouse.

Procedure 10.1. Editing an existing feature

1. Select the layer containing the feature you want to edit in the Layer Stack

2. Select the feature to edit in the Map View

3. Choose Edit > Edit Selected Feature.

(or double-click the feature when you are using the Identify icon in the Map pane)

The map pane goes into Edit mode. When you are in Edit mode, a partially transparent backdrop
shows up behind the features you are editing to allow you to discern between what you're editing and
the rest of the map. The color and opacity of this layer can be adjusted (see Procedure 10.3, “Changing
Edit Backdrop Color”). The original shape is also shown in the editing background. Here is an example
of what the map window looks like in Edit mode.
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Figure 10.1. Map view in Edit mode

4. Now you can change the geometry of the selected features. For example, you could move the location
of a city or the path of a road.

There are certain restrictions placed on Cartographica while you are in Edit mode:

While in Edit mode:

• Holding the Option key on your keyboard and clicking your mouse adds a new point after the cur-
rently selected point.

• Pressing the Delete key on the keyboard or choosing Edit > Delete will delete the selected point.

• Multiple points may be selected at the same time and will move in unison.

• Using the arrow keys will move the selected point in the appropriate direction (autorepeat is enabled).

• To close a polygon, commit changes with it still open. Cartographica will add a terminal point at
the same location as the origin.

• All zoom controls function normally, except typing in the zoom box.

5. Save or cancel your changes:

• To save (commit) your changes after editing, press Enter on the keyboard or choose Edit > Edit
Selected Feature again.

• To cancel your changes, press the Escape key on the keyboard.

Undo is handled separately when editing to preserve as much context as possible. So, when in edit
mode, the undo/redo are used for each individual editing operation (like moving, deleting, or adding
a point). Once you leave the edit mode (assuming you accepted the changes), these steps are forgotten
but you will be able to undo the entire editing operation.
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Once you have exited out of Edit mode and saved your changes, the changes are reflected in the Point
Data window.

Procedure 10.2. Adding a New Feature

1. Select the layer where you want to add the feature in the Layer Stack

2. Choose Edit > Add Feature

If the selected layer has no content (and therefore isn't associated with a particular shape type), you
are prompted for whether the new shape layer will be a point, line, or polygon.

The map pane goes into Edit mode just like when editing a feature. The same constraints apply to
adding a feature as when editing a feature.

3. To add a new point to a feature in editing mode hold the option key on the keyboard and click to add
the point.

4. Save or cancel your changes:

• To save your changes after editing, press Enter on the keyboard or from the Edit menu, select
Edit Selected Feature again.

• To cancel your changes, press the Escape key on the keyboard.

Once you have saved your changes and exited out of Edit mode, the features you have added to the
layer are viewable in the Point Data window.

Procedure 10.3. Changing Edit Backdrop Color

1. Choose Cartographica > Preferences… to bring up the Cartographica Preferences window

2. Click Edit Backdrop Color color well

The Color Picker will open

3. Select the color for the editing backdrop

The Opacity slider determines how much of the background layer shows through to the editing view.
To hide all other features, set Opacity to 100%. To disable the Edit Backdrop layer, set Opacity to
0%.

4. Close the Color Picker

Occasionally, geospatial data needs to be corrected by changing coordinates to be more accurate. In these
cases, changing values directly in the point window might be more appropriate, especially when correcting
obviously erroneous data.

Cartographica has the ability to change any existing point in any feature using the Point Data window.

Procedure 10.4. Precision Editing Features in the Point window

1. Select the layer in the Layer Stack

2. Select the data you want to change (either in the Data View or Map View)
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3. Choose Window > Show Point Data

The Point Data window appears showing the currently selected feature's geometry.

Figure 10.2. Point Data Window

4. To change a point, click on a coordinate and type in a new coordinate value.

5. If you need to add or remove a point, select the line containing the point and use the + and - buttons
to add or remove it. Of course, undo is available to undo whatever changes you have made.

Points are always edited in their original projection (CRS), so if your map is displayed in state plane,
but the data you're editing is in Lat/Long, the editing will be in Lat Long unless you Reproject the
points in the layer.

10.2. Merging and Splitting Features
You can use the Merge Selected Features command to join geometries. This will work best for overlapping
geometries, as they will result in a single part. If the parts are discontiguous (even if in a very small way),
then they will be considered separate parts and you will end up with a multi-part geometry. There are two
modes for this selection: intersection (features where any point is contained in the selection area) and
containment (features where all points are contained in the selection area). REWRITE

Procedure 10.5. To merge selected features into one

1. Select the features you want to merge.

2. Choose Edit > Merge Selected Features

The features you have chosen are merged onto one feature containing each of your selections. The
previous geometries will be removed.
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Procedure 10.6. Splitting a multi-part feature into separate features

1. Select the feature to split

2. Choose Edit > Split Selected Features

The feature you have chosen will be split into one new feature for each independent part in the existing
feature. All feature data will be copied to each newly created feature. The original feature will be re-
moved.

In the case of complex polygons with islands and holes, the islands will be separated into
new features and the holes will be assigned to the closest encompassing island.
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Chapter 11. Exporting Data
One of the benefits of having a desktop GIS is the ability to output data in a number of formats. Cartograph-
ica has extensive export capabilities to provide for just this type of operation. Generally, Cartographica
can export entire Maps or just individual layers (or selected data within those layers). Which option is right
for you depends on what you're trying to achieve.

11.1. Exporting Entire Maps
Cartographica can export Maps in a number of formats including (but not limited to):

• ESRI Shapefile
• GML
• KML
• MapInfo TAB
• MapInfo MIF
• Atlas BNA
• Adobe Illustrator

This will export the entire map either as a single file (if the format allows) or as one file per layer (if the
format only handles single layers). You can also choose to not export invisible layers, to reduce file size
and complexity.

Procedure 11.1. To export an entire map

1. Choose File > Export Map

2. Select the export format from the Export Format menu

3. Check Export Visible Layers Only to limit the exported data to layers that are currently visible.

4. Choose a file name for the export and click Save

Warnings will show up in the export window to describe certain aspects of the exported data:

• CRS can't be saved, map will be re-projected to native CRS : The target format doesn't support
multiple CRS's and the CRS that you are currently using doesn't match it's format, so Cartographica will
transform the data appropriately before writing it out.

• Format doesn't support multiple geometries: A file will be created for each layer

• Data fields won't be importable: data tables can't be exported and won't be importable as data into
other programs.

• Some geometries won't be accurate: the selected file format doesn't have accurate ways to save all
geometric types, so this format cannot be used to import data later. Cartographica will produce output
that is as close as possible to what you see on the map display.

• CRS can't be saved: the file format is device-independent and there is no place to indicate what format
the data is in.
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• Format does not support layers: Groups of features of specific types will be indistinguishable from
other groups. There is support for multiple kinds of features, but not layers. As such, a single file will
be created, but all polygons will be in a single polygon store, same for points and lines.

11.1.1. Exporting Maps to KML
When exporting to KML, all data is exported as data in the layers. However, much of that data is not un-
derstood by Google Maps or Google Earth. In the future, it is possible that other programs will understand
it. Cartographica exports the feature names based on either the default feature name, the label, or the feature
ID. The data that shows up when you click on a feature in Google Earth or Google Maps will be either all
data or just the data selected in the Layer Info Pop-up box. Cartographica exports all layers in their current
hidden/shown state unless Export Visible Layers Only is checked.

Here is a figure showing our example map and data of Canada exported to KML and then opened in Google
Earth. You can see the convex hull in eastern Canada as well as all of the roads that existed in the original
map in Cartographica.

Figure 11.1. Cartographica map exported to KML and opened with Google Earth

Procedure 11.2. Setting display fields for KML Export

1. Choose Windows > Show Layer Info to bring up the Layer Info window

2. Click on the Fields tab to show the field information

3. For each field that you would like to be displayed in the KML pop-up, check the Popup box.

This same box controls what information is displayed when Map > Show Data Tooltips is
selected.
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Procedure 11.3. Setting the name of features for KML Export

1. Choose Windows > Show Layer Info to bring up the Layer Info window

2. Click on the Info tab to show the general layer information

3. Choose the column name from the Feature Name pop-up

This same pop-up controls what the name of the feature when Map > Show Data Tooltips
is selected.

11.1.2. Exporting Maps to Adobe Illustrator
Exporting data to Adobe Illustrator is very similar to exporting to KML. All of the data is exported, but
Illustrator can't always see it. The Features are named using the same technique as in KML above.

Cartographica exports each layer in the map to a separate layer in the Adobe Illustrator file. If the layer
has labels, a separate Illustrator layer is exported just for the labels (allowing you to toggle these labels on
or off as necessary after exporting). Finally, Cartographica exports a legend for each layer in the map,
providing the basic style key for designers who use the Illustrator files.

When exporting to Illustrator, Cartographica also has the ability to embed the data for the layers into the
Illustrator file, which is useful when working with third-party plugins, such as Avenza MAPublisher
[http://www.avenza.com/mapublisher]. ClueTrust and Avenza have been working to make sure that maps
exported from Cartographica and imported into Illustrator when using MAPublisher are the easy to manip-
ulate and full of rich data. As such, when you check the Include data in export box while exporting to
Illustrator, georeferencing, CRS (Projection) and column data is exported along with the feature data and
the styles.

Here is an illustration of a map of Canada exported and then opened in Adobe Illustrator CS5.
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Figure 11.2. Cartographica map exported and opened with Adobe Illustrator

11.2. Exporting Layers and Features
For some purposes, it is important to export only feature data, such as cases where you are sending data
off for further processing or research using another GIS.

Cartographica exports individual features in ESRI®'s Shapefile format.

Procedure 11.4. Exporting an individual layer or selection

1. Select the Layer that you want to export from the Layer Stack

2. Begin the export process

• Choose File > Export Layer Features

• Choose File > Export Selected Features if you want to export just the selection).

3. Optionally select the character set (UTF-8 will be the default.)

4. Enter a file name and click Save.
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11.3. Exporting A Web Map
One unique feature of Cartographica is the ability to create a click-able web map from geospatial data. By
using the layers of the map to create a web-compatible image file and then using the data in the data table,
it can make each click-able area correspond to a link on the site or on another site. It can also provide roll-
over text.

Procedure 11.5. Creating a web map

1. Choose File > Export Web Map.

The Export Web Map sheet appears.

Figure 11.3. Export Web Map Sheet

2. You will be prompted to provide the following information:

• Selection Layer - The layer which is used to bound the selections. This must be a polygon layer.

• URL Column - The column that contains the URL (if any) that should be the target of the link.

• Label Column - The column that contains the label to be used for the target of the link.

• File Format - The type of image file (JPEG, GIF, TIFF, or PNG) to create for the map.

• Width and Height - The dimensions of the map to be produced.

• Quality (JPEG Only) slider - If you have chosen JPEG as the file format export format, the
Quality slider allows you to choose the level of quality for the output image. A lower quality also
guarantees a smaller (byte-wise) image.

3. Once you have set all of the information options, click Export.

Two files will be created for you: an image file and an HTML file in UTF-8. The HTML file contains
the geometric information and the links which serve as the basis for a web page that will contain the
map.
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11.4. Exporting Maps as Pictures
Occasionally, you will need to take a map from Cartographica and produce an image file from it in order
to include it in another document or use it in some other manner. Cartographica provides an easy mechanism
to create georeferenced images that accurately portray the data on the Cartographica map at the time.

Procedure 11.6. Export a Map as Picture

1. Choose File > Export Map As Picture…

The Export Map As Picture sheet appears

Figure 11.4. Export Web Map Sheet

2. Choose an image format from the Format pop-up menu

3. Enter the desired width and height in the appropriate boxes

4. Click Save

The requested image file, along with a world file (usually tfw, jgw, or pgw) and a projection file (prj)
will be created in the folder requested.

Some programs will understand the world files and some will import the prj files, but not
necessarilly all, so it is often desirable to use a standard CRS when exporting if you plan on
importing the file into another spatially-aware program.
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Chapter 12. Producing Printed Output
Cartographica has two ways to create printed output: Quick Printing and Map Layout printing.

As one might expect, Quick Printing provides a quick way to create printed output for use either on the
screen or in a PDF. It's no-frills and represents exactly what is currently on the screen.

Map Layout is much more sophisticated printing mechanism which uses a Map Layout document to define
the way that the map will look on the printed page. In exchange for the additional complexity, Map Layout
provides a way to print more than one map on a page and to add adornments, such as legends, scale, north
arrows and more.

12.1. Quick Printing
Quick Printing is the easiest way to print a basic map. By choosing File > Print Cartographica will print
a copy of the current map in as large a format as possible for whatever printer you are using. The larger
the print area, the more well-defined the printout.

You can print different format maps by using the File > Page Setup command to set and change the size
of the paper to use as the destination for the Map Layout.

PDF maps can be created by using File > Print and then using the PDF menu in the Print window to save
a PDF file. These files also pay attention to the Page Setup settings.

Procedure 12.1. Quick-Printing the current map

1. With your map open, choose File > Print…

The standard Print window will come up with a preview area to the left.

2. Choose the image resolution from among the available options

3. If you want to print just the area that was visible in the map window, check Print Visible Extent
Only

4. Change any other printer settings and print as you normally would.

12.2. Complex Map Layout
Cartographica has a second format for creating maps intended for production output. The Map Layout
document can refer to any Cartographica Mapset file (or combination of files) and can contain maps, titling,
scales, and legends. Map Layout documents contain a single page based on the Page Setup.

Cartographica supports scaling the view of the Map Layout so that it can be seen both in detail (zoomed
in) and as an overview for large printouts (zoomed out). The size of the page is determined by the Page
settings which can be changed by choosing File > Page Setup.

Procedure 12.2. Create a new Map Layout

• Choose File > New Map Layout

The new Map Layout window will appear, representing your newly created document
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Figure 12.1. New Map Layout window

The easiest way to add new elements to the Map Layout window is to use the toolbar at the top of the
window.

You can also add elements to the Map Layout window through contextual menus, otherwise known as
right-clicks or Control-clicks. Control-clicking in most areas of the Map Layout will show a menu which
will then provide you with options for editing the information or adding information.

When you open the Map Layout context menu by selecting the map, holding the Control key on the Keyboard
and clicking your mouse, this is what the menu looks like.
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Figure 12.2. Map Layout Context Menu

Procedure 12.3. Placing a Map into the Map Layout Window

To add a map into a map layout, the map must already be saved to disk. If the map you are working
on is not available (named Untitled), you will not be able to add it to the map layout.

1. Do one of the following to place the Map

•

Using the Add New Map toolbar icon ( ), drag a rectangle in the map layout window to the
size you want the map to be and release.

• Choose Insert Map from the context menu

The map appears in the window.

2. Adjust the size and location of the Map by clicking once on the Map to select it and then dragging it
in the window.

This is an example of a Map inserted into a map layout .
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Figure 12.3. Map Layout containing a Map

Once a map is in place on the Map Layout, you may change the map set referred to by the map (and any
associated legends and scales) by selecting the map and using the Change Map command from the con-
textual menu to re-target it to any map in a currently open Mapset Document.

You can add multiple maps to the same Map Layout page and they can refer to either the same or different
Mapset documents. Scale, pan visible layers in these maps are independent of each other.

Layer visibility in maps in Map Layout documents are handled independently from the more dynamic Map
Windows. Initially, visible layers in the Map Window are propagated to the Map Layout copy of the map.
Although features are updated live (along with styles), the hidden state of layers is not updated.

Procedure 12.4. Changing the visible Map area in Map Layout

Cartographica Maps that are embedded in a Map Layout can be zoomed and panned independently.

1. Click on the Map in the Map Layout window to select it.

This will cause the handles to appear around the map signifying that it is selected

2. Click again on the Map to make it active
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The box surrounding the Map will become blue signifying that the Map is now in focus. At this point,
many commands for navigating and controlling the Cartographica Map Window now become usable
in this map.

3. To zoom the map, use the items in the View menu or use the Zoom Tool (choose Map > Zoom Tool)
to zoom the map.

4. To pan the map, choose Map > Pan Tool and then drag inside of the Map to move

Procedure 12.5. Including or excluding layers from a Map (from Map View Details…)

Layer visibility in maps in Map Layout documents can be adjusted using the Details… popover

1. Click on the Map in the Map Layout window to select it.

This will cause the handles to appear around the map signifying that it is selected

2. Control-click (or right-click) on the Map Layout window to bring up the context menu and select
Details…

This is an example of a Details… popover when displayed

Figure 12.4. Details… popover example

3. Check or uncheck layers as desired
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Procedure 12.6. Including or excluding layers from a Map (from within the map
view)

Layer visibility in maps in Map Layout documents can be adjusted using the Element popover. Initially,
visible layers in the Map Window are propagated to the Map Layout copy of the map. Although features
are updated live (along with styles), the hidden state of layers is not updated.

1. Click on the Map in the Map Layout window to select it.

This will cause the handles to appear around the map signifying that it is selected

2. Click again on the Map to make it active

The box surrounding the Map will become blue signifying that the Map is now in focus.

3. Use control-click (or right-click) to bring up the context menu and toggle each layer with the named
entry. Layers which are visible in this particular Map are checked.

Map Layouts are designed for a single page, but that page may be of any size. Choose File > Page
Layout to change the page size. Page size changes take effect immediately and provide a good
way to target large-format printers.

12.3. Placing elements in the Map Layout
Once you have placed a map, you may place titles, scales, legends or compasses to further customize the
appearance of the printed layout.

Procedure 12.7. Adding a scale box to Map Layout

1. Add the Scale Box:

• From the Map Layout Toolbar, choose the New Scale Box toolbar icon.

• Choose Add Scale from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Scale to be and release.

The scale box appears in the map layout window.

Procedure 12.8. Customizing a scale box

1. Double-click the scale box

The Scale Box Options sheet will appear
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Figure 12.5. Scale Box Options sheet

2. Set Scale Units to one of the following:

• Automatic

• Standard (auto scale)

• Metric (auto scale)

• Or one of the measurements

3. Set the size of the Scale

• Choose Fixed Size in Scale Units to set the length of the scale bar to a particular number of
units

• Choose Fill Scale Box to have Cartographica use whatever length comes closest to filling the
scale box on the page

Since 1.5.4, the Cartographica Preferences window contains preferences that control the units
that are used as the default units for new Scale boxes (for both area and linear measurements).
These preferences are used for new scale boxes.

4. Click OK to apply the changes

Procedure 12.9. Adding a legend to Map Layout

1.

From the Map Layout Toolbar, choose the New Legend toolbar icon (  ). .

or choose Add Legend from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Legend to be and release.

The Legend box appears in the map layout window.

You can now position or resize the Legend as desired. When you place a legend, items are grouped
together in a manner so as to use all the available space efficiently without becoming confusing. If
there are multiple styles defined in a single style, they are grouped under the layer name, otherwise,
the layer's style swatch appears to the left of the style.
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When there is insufficient space to display all features of the Legend, a yellow warning triangle shows
up at the bottom of the rectangle to indicate that there is a drawing issue and that the box needs to be
expanded.

Procedure 12.10. Including or excluding layers from a Legend (using Details…)

Legends can contain any subset of available layers in their associated maps. Initially, all visible layers are
added to the Legend when it is inserted in the Map Layout. This can be changed after the Legend is added
from either the pop-up menu for the Legend, or from the Details… popover.

1. Click on the Legend in the Map Layout window to select it.

This will cause the handles to appear around the map signifying that it is selected

2. Use control-click (or right-click) to bring up the context menu and choose Details….

This will present the Layout Details popover

Figure 12.6. Layout Details popover for Legend

3. Choose the content of the Legend:

• To show the legend for every visible layer in the associated Map (in the Map Layout document),
select Show all visible map layers.

• To show the legend for the selected subset of layers in the associated Map (in the Map Layout
document), select Show all visible map layers.

Legends will only be shown for layers that are selected for display in the associated Map view,
even if you have chosen the layer to be displayed in the legend manually.

Procedure 12.11. Including or excluding layers from a Legend with menu

Legends can contain any subset of available layers in their associated maps. Initially, all visible layers are
added to the Legend when it is inserted in the Map Layout. This can be changed after the Legend is added.
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1. Click on the Legend in the Map Layout window to select it.

This will cause the handles to appear around the map signifying that it is selected

2. Use control-click (or right-click) to bring up the context menu and toggle each layer with the named
entry. Layers which are visible in this particular Map are checked.

3. To synchronize with the current visible layers in the associated Map (in the Map Layout document),
choose Synchronize with Map from the context menu.

Procedure 12.12. Adding a compass to Map Layout

1. Add a Compass by doing one of the following:

•

From the Map Layout Toolbar, choose the New Compass toolbar icon (  ).

• Choose Add Compass from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Compass to be and release.

The Compass box appears in the map layout window.

Procedure 12.13. Adding a Text Box to Map Layout

1. Create a Text Box

•

From the Map Layout Toolbar, choose the New Text Box toolbar icon (  ).

• Choose New Text Box from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Text Box to be and release.

The Text box appears in the map layout window.

You can now position or resize the Text Box as desired.

To change the fonts used in Scale, Legend, and Text items, select the item and then use the Macintosh
Font Panel (choose Edit > Show Fonts menu) to change the text attributes.

Here is an example of a Map Layout window with all of these elements added:
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Figure 12.7. Scale, Legend, and Text Box added into map layout window

When a map is selected (or one of its related layout features, such as the scale or legend), then all related
layout features are badged with a blue dot to indicate that they are related. When not selected, the blue dot
disappears.
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To move items in the Map Layout, click once on the item to select it (you should see "handles" in each of
the corners and along the edges), and then drag the item to its desired location.

To resize any of the items in the Map Layout, click once on the item to select it and then drag one of the
handles to change the size of the item.

Map Layout items associated with a given Map will show an indicator in the lower-left-hand corner of the
item in order to represent the connection between these items. Thus, if you click on a Scale for a Map that
also has a Legend, all three items will be "badged" as being related to each other.

Some Map Layout items have yellow warning triangles ( )when there is something wrong with the
visual presentation. For example, Legends may have this indicator when there is not enough room in the
item to show the entire legend. To fix this, either remove items from the legend, change the font, or resize
the legend box.

Procedure 12.14. Removing Map Layout objects

1. Select the object you wish to delete

2. Choose Edit > Delete.
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Chapter 13. Column Formulas
13.1. Introduction to Formulas

Cartographica supports formulas in columns, providing a way to compute new values from existing columns
or from geometric attributes of the feature for which the column is being calculated. The formula interpreter
uses an embedded python interpreter with the basic functions plus the math library imported at the base.
This chapter lists the functions and constants available.

Cartographica uses an embedded Python 3 interpreter to interpret the formulas, or "expressions" that make
up the Column Formulas. This provides an enormous amount of flexibility in these expressions and although
we detail the key aspects of python expressions, basically anything that can be executed as a python expres-
sion is fair game in a Column Formula in Cartographica.

The simplest expression is just a replacement value. Although it's not the best use of processing power, it
is an effective way to put a constant value in a column as a placeholder.

The most common use of Column Formulas is to create a new value based on the values of another column
or columns in Cartographica. To create these simple relationships, use standard arithmetic operators (below)
to combine fields.

Example 13.1. Arithmetic calculation

For example, a population column and an area column can be combined to determine density.

POPULATION / AREA

Example 13.2. Extract sub-string

Another use of Column Formulas is to create new columns by splitting data that has been encoded into a
string. For example: a column named CITYSTATE containing Washington, DC may be appropriate
for an address line, but may not be appropriate for your needs, so you could use .

CITYSTATE.split(',')[0].strip()

to grab the city and

CITYSTATE.split(',')[1].strip()

to grab the state from the CITYSTATE column. Breaking this down:

1. the split method splits a string into an array of sub-strings that were previously separated by the character
in quotes (,)

2. that array is dereferenced to it's 2nd element (python's understanding of the world is based on the 0 being
the first position)

3. that string has the strip method run against it, which removes spaces from the start and end of the
string

Thus, you get the state.
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Example 13.3. Extract string by position

Or if you had a column BLOCKGROUP containing a block group identifier 210670001001 and wanted
to pull out the FIPS State and county code from it, you could use:

BLOCKGROUP[0:5]

to grab the city and

CITYSTATE.split(',')[1].strip()

(pulling the first 5 characters, starting at position 0 from the text string).

Thus, you get the state.

Version 1.5 Change

Versions of Cartographica prior to Version 1.5 used the built-in Python 2.7 interpreter on macOS
to interpret functions. In versions, 1.5 and later, a version 3.8+ interpreter is used. For most uses
in Cartographica, this does not change the behavior, however string functions are now mostly
methods on string objects (as shown in the Example 13.2, “Extract sub-string” example above),
and thus must be called on the text string objects, as opposed to called directly.

Cartographica will attempt to warn you when you have an old-form function in use, so that you
may change it to the new method-based invocation.

Fortunately, the 1.5 methods are compatible with 1.4.x, so you can safely change the formulas
and save them for MapSets that are in use by both.

Procedure 13.1. Creating a Column Formula

1. Select the layer in which you want to create a formula in the layer stack

2. Choose Window > Show Layer Info to bring up the Layer Info window.

3. To create a new column in the layer, click on the + button or choose, Layer > Add Column

4. Click on the new column name and change its name to something meaningful

5. Click the Set Formula… button to bring up the formula sheet

Figure 13.1. Formula sheet
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6. Drag a column name from the bottom pane to add a reference to another column to this formula.
Colors of the column names denote the type of data.

7. Now add the rest of the formula by typing in the formula area and dragging other column references
to it.

8. When you are done, click OK to set the formula

While you enter the formula, Cartographica is constantly evaluating it looking for potential problems and
providing you guidance in how to solve those problems. Unfortunately, there are some errors for which
Cartographica cannot determine the problem and can only tell you that the result would be invalid.

For other cases, consult the Expression Warnings table for meanings and suggested solutions to problems
detected by Cartographica.

Table 13.1. Expression Warnings

MeaningWarning Message

This expression results in no value. Generally this is
the result of calling a function that doesn't return a
value

No result value for test data

This expression evaluates to an arithmetic error using
the test data. This warning indicates that under some

Math error-some fields may be wrong/missing

circumstances (possibly all), field values will not be
set. A common cause of this is an expression that
results in infinity or attempts to divide by zero using
the test data.

This expression is invalid. This is often displayed
during typing due to issues such as missing parenthes-
is, missing operators and other errors.

Syntax error in formula

This expression is invalid in a way that we cannot
determine.

Interpreter exception

The result of the expression will be a geometry. The
most common cause of this is a missing final expres-

Geometries can't be stored in columns

sion when evaluating a centroid or other geometric
value.

The result of this expression will be an unknown
type. Because of this, no data will be stored in the

Unknown type

resultant column. Check that any functions used in
the expression don't return complex types, such as
geometries

The result of this expression references an attribute
(using dot notation) that is not known to the interpret-
er. Check the spelling of anything after a dot.

Unknown attribute

The referenced symbol is unknown to the interpreter.
This is generally caused either by putting two column

Unknown symbol:

references next to each other without an operator or
by a typo

A function in this expression that works on a geo-
metry is being used with the wrong type of geometry.

Wrong geometry type
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MeaningWarning Message

For example: you are trying to take the area of a
point.

The expression uses some geometry function incor-
rectly, resulting in confusion for the geometry pro-
cessor

Other geometry error

Internal error, please report to ClueTrust
[https://support.cluetrust.com]

Can't initialize interpreter

Cartographica does not resolve circular references or directional references. Each column is executed
in column order when they are loaded and are updated when they are changed. As such, if you
have a Column Formula that is dependent on another Column Formula, you may experience un-
expected results.

To refresh an individual value, just set the formula again.

13.2. Conditional Expressions
Cartographica supports conditional expressions to provide for complex calculations, such as discontinuous
functions. These functions may be nested, so that decision trees can be implemented with great flexibility.

The format for conditional expressions is true_expression if condition else false_ex-
pression. In this case, the expressions can be any other expression, including a nested conditional ex-
pression, so it is possible to create a conditional expression of arbitrary complexity by chaining them to-
gether.

Parenthesis around the condition are optional but are useful for clarification.

Example 13.4. Conditional Function Example

For example, if you were to need a function that takes a number and rounds to the nearest 500 in the case
that the number is positive, but clamps to zero in the case the number is negative, you could write it like
this:

trunc(VALUE/500)*500 if (VALUE>0) else 0

This would result in a value of 0 for all values <500, 500 for all values between 500 and 1000, 1000 for
all values between 1000 and 1500, etc.

13.3. Mathematical functions
• int int(any value);

any value ;

This function converts between any data type and an integer value.

• float float(any value);

any value ;

This function converts between any data type and an floating point value.
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• float ceil(x);

float x ;

Returns the ceiling of the x as a float, the smallest integer values greater than or equal to x.

• float copysign(x, y);

float x;
float y ;

Returns x with the sign of y. copysign(2,-1) returns -2.

• float fabs(x);

float x ;

Returns the absolute value of x.

• int factorial(x);

int x ;

Returns x factorial. Fails if x is not an integer or is negative.

• float floor(x);

float x ;

Returns the largest integer value less than or equal to x.

• float fmod(x, y);

float x;
float y ;

Returns x modulus y.

• float frexp(x);

float x ;

Returns x with the mantissa and the exponent as separate components of a pair (m,e), such that x=m*2e.
To use one or the other, you must refer to them as a subscript, thus [0] for the mantissa and [1] as the
exponent.

• float fsum(any value);(...);

any value ;

Returns the sum of all values in the list.

• bool isinf(x);

float x ;

Returns True if x is infinite, False otherwise.
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• bool isnan(x);

float x ;

Returns True if x is the IEEE NAN value, False otherwise.

• float ldexp(x, i);

float x;
int i;

Returns x *2^i.

• float modf(x);

float x;

Returns the fractional and integer parts of x as a pair (f,i) such that x=f+i. To use the individual compon-
ents, they must be accessed by subscript, thus [0] for the fraction and [1] for the integer.

• float trunc(x);

float x;

Returns x truncated.

• float exp(x);

float x;

Returns e *x.

• float log(x, base);

float x;
[floatbase];

Returns the natural logarithm of x if there is only one parameter. Returns the logarithm of x given base,
calculated as log(x)/log(base).

• float log1p(x);

float x;

Returns the natural logarithm of 1+x (base e).

• float log10(x);

float x;

Returns the base-10 logarithm of x. Generally more accurate than log(x,10).

• float exp(x, y);

float x ;
float y;

Returns x^y.
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• float sqrt(x);

float x;

Returns the square root of x.

13.4.Trigonometric Functions
• float acos(x);

float x;

Returns the arc cosine of x, in radians.

• float asin(x);

float x;

Returns the arc sine of x, in radians.

• float atan(x);

float x;

Returns the arc tangent of x, in radians.

• float atan2(y, x);

float y;
float x;

Returns the arc tangent of x/y in radians. The result is between -pi and pi. Differs from just using the
arc(x/y) because it can use the sign of each number to determine which quadrant to put the result in.

• float cos(x);

float x;

Returns the cosine x radians.

• float hypot(x, y);

float x;
floaty;

Return the Euclidean norm, sqrt(x*x+y*y). This is the length of the vector from the origin to point
(x,y).

• float sin(x);

float x;
Returns the sine x radians.

• float tan(x);

float x;
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Returns the tangent x radians.

• float degrees(x);

float x;

Converts the angle x from radians to degrees.

• float radians(x);

float x;

Converts the angle x from degrees to radians.

• float acosh(x);

float x;

Returns the inverse hyperbolic cosine of x.

• float asinh(x);

float x;

Returns the inverse hyperbolic sine of x.

• float atanh(x);

float x;

Returns the inverse hyperbolic tangent of x.

• float cosh(x);

float x;

Returns the hyperbolic cosine of x.

• float sinh(x);

float x;

Returns the hyperbolic sine of x.

• float tanh(x);

float x;

Returns the hyperbolic tangent of x.

13.5. Mathematical Constants
These constants are available for use in formulas in Cartographica:

• pi

The mathematical constant pi.
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• e

The mathematical constant e.

13.6. Geometric Functions
These geometric functions are available for use in formulas in Cartographica. To use them, you must always
specify geometry.function(parameters). For example, to obtain the area of the current geometry
(valid only for polygons), you would use geometry.area().

• float geometry.area(useBase);

[bool useBase];

Returns the area in the current coordinate system units, using either the map coordinates (useBase is 0
or not present) or the original layer coordinates (useBase is 1).

This function is only available for polygons.

• float geometry.length(useBase);

[bool useBase];

Returns the length in the current coordinate system units, using either the map coordinates (useBase is
0 or not present) or the original layer coordinates (useBase is 1).

This function is only available for polygons and lines

• float geometry.bbox(useBase);

[bool useBase];

Returns the rectangle of the bounding box of the current geometry using either the map coordinates
(useBase is 0 or not present) or the original layer coordinates (useBase is 1).

The return value is a structure containing x,y,width, and height. To access each individual element, use
the dot notation: geometry.bbox().x to retrieve the x coordinate, for example.

• float geometry.midpoint(useBase);

[bool useBase];

Returns the midpoint of the line in the current coordinate system, using either the map coordinates
(useBase is 0 or not present) or the original layer coordinates (useBase is 1).

This function is only available for lines.

• float geometry.centroid(useBase);

[bool useBase];
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Returns the centroid of the feature in the current coordinate system, using either the map coordinates
(useBase is 0 or not present) or the original layer coordinates (useBase is 1).

This function is only for points, multipoints, and polygons.

13.7.Text Functions
The following text functions are available for use in formulas in Cartographica. To use them, they must
always be "attached" to a string object, as they are string object methods, as opposed to pure functions.
Therefore, if you have a string column named my_value, you must use my_value.upper() to convert
this to upper case. The length function, len(my_value), is a generic function and thus still must surround
the string variable.

Also note that strings use collection operators as well, so if you want the first 2 characters of a string, you
may retrieve them by using my_value[0:2]; similarly, the 3rd and 4th characters may be retrieved by
using my_value[2:4]. In addition, negative numbers connote references from the end of the string,
so my_value[-2:] would retrieve the last 2 characters at the end of the string (the lack of a number
after the colon connotes until the end).

1.5 Change

For those who have used Text functions in the past, there was a change in version 1.5 and beyond
because of the adoption of a new Python 3-based back-end. In Cartographica 1.5 and beyond, Text
functions are object methods and not pure functions. This means that if you previously used up-
per(my_value) to convert my_value to uppercase, then you now must use my_value.up-
per(). Cartographica will present an error or warning if this change affects existing formulas.

• str .capitalize();

Returns text in title case. First letters of words are made upper case, with the remainder lower.

• str .upper();

Returns text in upper case.

• str .lower();

Returns text in lower case.

• int .find(sub, start, end);

str sub;
int start;
int end;

Returns the location that the string sub is found within the string (starting at the beginning).

Optional parameters are start and end, the starting and ending locations of the search.

• int .rfind(sub, start, end);

str sub;
int start;
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int end;

Returns the location that the string sub is found within the string, starting at the end.

Optional parameters are start and end, the starting and ending locations of the search.

• int .count(sub, start, end);

str sub;
int start;
int end;

Returns the count of the number of times that the string sub is found within the string.

Optional parameters are start and end, the starting and ending locations of the search.

• int .split(sep, maxsplit);

str sep;
int maxsplit;

Returns an array of text strings that are separated by the text string sep, optionally with a maximum
number of splits, maxsplit. If the separator (sep) is omitted, the algorithm will use consecutive
whitespace as the split.

'1,2,3,4'.split(',') returns ['1','2','3','4']

This method is especially useful for creating new columns out of columns that may have been strings
with multiple values previously. For example, let's say you have a column for the City, State of an address
named CITYSTATE and containing Washington, DC for example. By creating two new columns
and using these formulas respectively:

City: CITYSTATE.split(',')[0].trim()

State: CITYSTATE.split(',')[1].trim()

you will get the City in one column and the State in the next.

Note that we use the 1st array element for the first and the 2nd array element for the second,
since array elements start with 0, not 1.

• int .join(array);

[str] array;

Returns a new string created by joining the elements of the string array by the string that the method is
executing on. This can be used in interesting ways to join values from other columns. For example,
given columns A, B, C and D, you can join them by hyphens by doing the following:

'-'.join([A,B,C,D])

in the above, we created an ad hoc array by putting the individual values between square
brackets and separated by commas.

• int .strip(stripchars);
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str stripchars;

Returns a new text string with the trailing and leading whitespace removed. If you pass a string in
stripchars, the method will remove those characters (instead of whitespace) from the leading and
trailing positions.

• int .rstrip(stripchars);

str stripchars;

Returns a new text string with the trailing whitespace removed. If you pass a string in stripchars,
the method will remove those characters (instead of whitespace) from the trailing positions.

• int .lstrip(stripchars);

str stripchars;

Returns a new text string with the leading whitespace removed. If you pass a string in stripchars,
the method will remove those characters (instead of whitespace) from the leading positions.

13.8. Date Functions
Although Cartographica isn't awash in great date functionality, mostly owing the the lack of solid date,
time, and timezone support in many geospatial data formats, it Column Formulas do have access to the
date functionality of Python, which means there are some sophisticated date capabilities available.

13.8.1. Use of date classes
Most of the date and time functions work on datetime objects, which are not usable by Cartographica
directly. However, they can be further operated on to retrieve the data stored within them by using day,
month, year (and hour, minute, second) accessors. For example datetime.today().day will
provide the integer day of the month.

Dates can also be converted into strings by using the strftime() method on a datetime object. For
example, datetime.today().strftime("%Y-%m-%d") will provide the current date in "YYYY-
MM-DD" form, or 2020-01-23 if it were the date this page was being written.

• datetime datetime.today();

Today's date as a datetime object.

• datetime datetime.utcnow();

Today's date and time in UTC as a datetime object.

• str .strftime(format);

str format;

String representation of the requested date using the specified format.

• int .weekday();

Return the day of the week as an integer (0=Sunday, 1=Monday, etc.).
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• str .ctime();

Return the date and time as a string in human-readable format.

• datetime datetime.strptime(date_string, format);

str date_string;
str format;

Create a new datetime object from the date_string using the requested format.

13.8.2. Date Format Strings
T h e  P y t h o n  d o c u m e n t a t i o n  d e t a i l s  t h e  d a t e  f o r m a t
[https://docs.python.org/3/library/datetime.html#strftime-strptime-behavior], however the strings used for
strftime and strptime are built from the following directives.

Table 13.2. Date Format Directives

ExampleMeaningDirective

01, 02, ..., 31Day of the month as a zero-padded
decimal number

%d

01, 02, ..., 12Month of the year as a zero-padded
number

%m

00, 01, ... 992-digit year as a zero-padded
number

%y

0000, ..., 2020, ...., 99994-digit year as a zero-padded
number

%Y

00, 01, ..., 2324-hour clock Hour as a zero-pad-
ded number

%H

00, 01, ..., 1212-hour clock Hour as a zero-pad-
ded number

%I

AM, PMAM/PM (or local equivalent)%p

00, 01, ..., 59Minute as a zero-padded number%M

00, 01, ..., 59Second as a zero-padded number%S

Table 13.3. Common Examples of Date Strings

Output ExampleString

2019-12-31%Y-%m-%d

23:59:59%H:%M:%S

12/31/19 23:59:59%m/%d/%y %H:%M:%S
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Chapter 14. Color Palettes
Color Palettes are groups of colors that are put together to achieve some specific effect. For ramps (con-
tinuous color) the colors show a smooth transition across a range of values, highlighting fast rates of change.
For segments (discontinuous color) the colors represent individual classes of information.

Cartographica has a sophisticated palette management system which provides tools to create, modify, import,
and use color palettes in any part of the program that uses color.

Colors may be dragged from almost any source and Cartographica will import palettes from the ColorBrewer
site (or anything that exports in a similar format).

Palette management is done through the Palettes tab of the Uber Browser, which provides editing and
previewing capabilities.

Figure 14.1. Uber Browser Showing Palettes Tab

The palette tab is composed of two primary sections. The Palette List at the top of the window, which
shows all available palettes that you have access to. The Palette Inspector at the bottom provides the tools
to view the particulars of the palettes and make changes to them.

The Palette List shows the name and preview of each palette and a locked symbol if the palette is not editable.

The Palette Inspector shows the colors in the selected palette and whether the palette is Continuous (Car-
tographica interpolates out the colors in between) or Segmented (the colors are repeated in between).

To learn how to use palettes with vector and raster layers, see Procedure 6.11, “Applying a palette of colors
to a set of styles” and Procedure 6.15, “Changing a Raster Layer's palette”
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Procedure 14.1. Create a new palette

1. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

2. Click the Add (+) button to add a new palette.

A single color palette will be added to the bottom of the list.

Since the new palette is selected, the Palette Inspector shows the current colors in the palette and the
Continuous button is selected.

3. Click on the name column and enter a new name for the new palette.

4. Click in the single gray-outlined box to add a new color to the palette.

Always click here to add a color to the end of the palette

5.

Procedure 14.2. Removing a palette

1. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

2. Click on the palette you wish to remove

Palettes with the lock symbol next to them will not be editable or removable

3. Click on the Remove(-) button

Figure 14.2. Color Picker

Procedure 14.3. Changing a color in a palette

1. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.
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2. Click on the palette in the Palette List to select it

The colors of the palette will now be in the Palette Inspector

3. Click on the color once to select it

If the Color Picker is already up, the color will appear in it ready to be changed at this point

4. Click on the color a second time to bring up the Color Picker

5. Change the color using the color picker and the palette will change in unison.

Procedure 14.4. Switching between ramp and segmented palettes

1. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

2. Click on the palette in the Palette List to select it

The colors of the palette will now be in the Palette Inspector

3. At the top of the Palette Inspector, click on the Continuous button (left) to change to a ramp color
palette or on the Segmented (right) to change the interpolation method.

Procedure 14.5. Reversing the colors in a palette

1. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

2. Click on the palette in the Palette List to select it

The colors of the palette will now be in the Palette Inspector

3. In the Palette Inspector, click on the reversal button to change the order of the colors.

Procedure 14.6. Pasting a color brewer palette

ColorBrewer [http://colorbrewer2.org/] is a well-known resource for creating meaningful palettes for maps.
Cartographica can accept palettes directly from the ColorBrewer site for use in the Palettes tab of the Uber
Browser. Although we specifically point at ColorBrewer for good palettes, Cartographica can import
Javascript-style CSS colors (hex,RGB,HSL) or a list of numbers where the Red, Green, and Blue components
are separated by commas and have a range of 0-255 and where colors are separated by semicolons.

229, 245, 249; 153, 216, 201; 44, 162, 95; 

or

['#e5f5f9','#99d8c9','#2ca25f']

1. Visit the ColorBrewer [http://colorbrewer2.org/] site to compose your palette

2. When you are done creating your palette, click Export Your Colors to bring in the export window

3. Copy the numbers in the box or just copy-n-paste

4. Switch back to Cartographica
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5. Choose Window > Show Uber Browser and click the Palettes tab to bring up the Palettes Tab of
the Uber Browser.

6. Choose Edit > Paste to past the palette into your Palette Window

7. Rename the color palette by clicking on the name and typing a new one.
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Chapter 15. AppleScript Scripting
Cartographica supports scripting through AppleScript in order to control the program and add customize
it for the functionality that your particular application needs. Support for scripting in Cartographica is ex-
tensive and it can be used to add, modify and delete Layers, Features, Columns and data related thereto.

Beyond support for basic data editing, Cartographica also provides scripting support for many of the built-
in commands that are available for analysis.

15.1. Scripting Architecture
The Cartographica scripting architecture uses a standard AppleScript paradigm which can be used by any
OSA (Open Scripting Architecture) compliant language to control and augment the application.

The primary object in Cartographica is a Document. Structured just like the Cartographica Mapset Document,
the Document object contains a list of Layers. These Layers, in turn, contain various properties and a list
of Features just like in Cartographica's MapSet Document.

15.2. AppleScript Vocabulary
As is standard for AppleScript, the full description of the vocabulary is contained in the Application itself
and visible to the standard AppleScript Editor (found in the Utilities folder inside of the Applications
folder). We have summarized the main objects and their use in Table 15.1, “AppleScript Main Objects” .

Table 15.1. AppleScript Main Objects

Cartographica MapSet DocumentMap Document

Cartographica Map Layout DocumentMap Layout Document

Window containing a MapSet DocumentMap Window

Window containing a Map Layout DocumentMap Layout Window

A component of a Map Window that shows the mapMap Viewer

Layer in a Cartographica Document, used to store
Features and dictate what they mean and how they
are presented.

Layer

Feature in a Layer, used to store Geometry and Field
Data for individual features.

Feature

An attribute of a Layer, used to store the Columns
and information about the columns.

Schema

An attribute of a Layer, the Style describes how the
features in a layer are presented. Used to store Style
Parameters.

Style

An attribute of a Style, the Style Parameter describes
how a particular class of Features that are displayed
using a Style are displayed.

Style Parameter

An attribute of a Feature, Geometry stores the geo-
metric attributes of a Feature. Made up of 1 or more
parts, which in turn are made up of geopoints.

Geometry
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Coordinate Reference Systems (sometimes referred
to in Cartographica and elsewhere as just projec-

Coordinate Reference System

tions). Global objects that can be assigned to layers
and Maps.

Contained in a Schema, each Column describes a
particular kind of data that is a part of the Feature's

Column

definition within a Layer. The Column contains the
type, length and other attributes.

Field Data are contained by a Feature and describe
the values for a particular Column as it pertains to
that Feature.

Field Data

Field Mappers are used to map fields between layers
for certain analysis operations.

Field Mapper

15.2.1. Visibility into the current Map Window
Versions of Cartographica prior to 1.4 could not interact with the visible map. Although this was not an
enormous problem, it did result in complications when trying to operate on a subset of layers or features
when performing scripted operations. In 1.4, Cartographica now exposes the Map Viewer, which in turn
exposes the selections in the layer stack and the map/data view, thus allowing you to write scripts that
work on the selected layers or features.

15.3. Example Scripts
This section contains some simple examples of what can be done with AppleScript scripting and Carto-
graphica.

Example 15.1. Setting a column value for all Features in a Layer

tell application "Cartographica"
 set targetlayer to layer "Businesses" of the first document
 repeat with aFeature in every feature of targetlayer
  set value of field data "Copyright" of aFeature to "© 2010, ClueTrust"
 end repeat
end tell

The example above demonstrates cycling through every feature in the targetLayer (in this case a layer with
the name "Businesses") and setting a value of the data field named "Copyright" to “©2010, ClueTrust”.

There are further example scripts on the ClueTrust Support site [https://support.cluetrust.com/] if you
search for AppleScript
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